本文介绍Windows实例配置IE代理服务器后Windows更新失败,提示“0x80d02002”错误的解决方案。
问题现象
在Windows系统的ECS实例中,配置IE代理服务器后出现Windows更新失败的问题,并提示“0x80d02002”错误信息。如下图所示:
问题原因
可能是由于Windows实例配置了IE代理服务器,导致WinHTTP代理服务器配置出现异常。
解决方案
如果您已配置了IE代理服务器并且其功能正常,可以将IE代理服务器配置同步至WinHTTP代理服务器,以解决由于WinHTTP代理服务器配置异常而导致Windows系统更新失败的问题。具体操作,请参见方案一:同步IE代理服务器配置。
您需要根据实际业务环境,使用IE浏览器来访问需要代理的网站或服务,以确保代理功能是否正常。
如果您不再需要保留代理服务器配置或同步IE代理服务器配置后仍未解决问题,可以取消代理服务器配置,使Windows更新不再受到代理服务器的影响,从而解决该问题。具体操作,请参见方案二:取消代理服务器配置。
方案一:同步IE代理服务器配置
远程连接Windows实例。
具体操作,请参见通过密码或密钥认证登录Windows实例。
打开CMD命令提示符。
右键单击图标,然后单击运行。
在运行对话框中输入
cmd
。单击确定。
进入CMD命令提示符。
执行以下命令,将IE代理服务器配置同步到WinHTTP代理服务器配置。
netsh.exe winhttp import proxy source=ie
若系统返回信息如下图所示,则表示成功同步IE代理服务器配置至WinHTTP代理服务器配置。
重新更新Windows系统,如果可以正常更新,说明问题已解决。
方案二:取消代理服务器配置
远程连接Windows实例。
具体操作,请参见通过密码或密钥认证登录Windows实例。
打开CMD命令提示符。
右键单击图标,然后单击运行。
在运行对话框中输入
cmd
。单击确定。
进入CMD命令提示符。
执行以下命令,取消WinHTTP代理服务器配置。
netsh.exe winhttp reset proxy
若系统返回信息如下图所示,则表示成功取消WinHTTP代理服务器配置。
取消IE代理服务器配置。
打开Internet Explorer浏览器。
单击页面右上角工具按钮,然后单击Internet选项。
在Internet选项对话框中,选择连接页签,然后单击局域网设置。
在局域网设置对话框中,取消勾选为 LAN 使用代理服务器选项,然后单击确定。
重新更新Windows系统,如果可以正常更新,说明问题已解决。