通过VNC/Workbench远程连接实例的问题

Workbench远程连接问题(Linux)

通过Workbench远程连接Linux实例时提示连接超时,怎么办?

问题现象

通过Workbench工具远程连接Linux实例时提示“登录主机:i-m5e****73a (47.*.*.157:3389) 失败,原因:链接超时!”错误。远程连接失败

问题原因

该问题通常是由以下原因导致:

  • Linux实例的安全规则中,禁止了通过Workbench工具连接目标Linux实例。

  • SSH进程使用的默认端口不是22端口。

  • Linux实例内的防火墙设置未允许Workbench工具连接目标Linux实例。

解决方案

请参考以下步骤进行排查:

  1. 查看目标Linux实例的SSH进程配置的访问端口。具体操作,请参见

    • 不是22端口

      在Workbench工具中通过修改后的SSH端口重试远程连接。

    • 是22端口

      请继续下一步检查。

  2. 查看目标Linux实例的安全组设置,检查SSH服务的端口是否放开。具体操作,请参见查询安全组规则

    说明
    • 此处的端口范围以SSH默认的端口22为例。如果您修改过SSH默认端口,此处应当为您修改后的端口号。

    • 授权对象如果不是0.0.0.0/0,则需要同时对您需要访问的ECS实例的IP地址进行授权,此处47.96.60.0/24和118.31.243.0/24为例。

    规则方向

    授权策略

    优先级

    端口范围

    授权对象

    入方向

    允许

    1

    目的:22/22

    • 源:47.96.60.0/24和118.31.243.0/24

    • 源:0.0.0.0/0

  3. 检查Linux实例中是否开启防火墙,且不允许Workbench工具连接SSH端口。检查步骤如下:

    1. 通过阿里云VNC方式登录Linux实例。具体操作请,参见使用VNC登录实例

    2. 检查防火墙状态。

      • 已开启,请关闭防火墙,然后重新通过Workbench工具尝试远程连接。

      • 未开启,请继续执行下一步排查。

    3. 如果您仍然无法通过Workbench工具远程连接,建议您选择阿里云VNC工具进行远程连接。

通过Workbench远程连接Linux实例失败时提示拒绝连接,怎么办?

问题现象

通过Workbench远程连接Linux实例失败,提示“登录实例失败:DefaultConnectFuture[root@/xxx.xxx.xx.xxx:22]: Failed (AnnotatedConnectException) to execyte: Connection refused: /xxx.xxx.xx.xxx:22”的错误。拒绝连接

问题原因

Linux实例未开启终端连接(SSH)或远程桌面(RDP)对应的远程服务。

解决方案

请排查以下问题:

  • Linux实例是否开启了终端连接(SSH)或远程桌面(RDP)对应的远程服务。若未开启需开启对应的远程服务。

  • Linux实例是否开放了连接端口。若未开放,需开放对应的连接端口,终端连接(SSH)一般开放22端口,远程桌面(RDP)开放3389端口。

通过Workbench远程连接Linux实例提示用户名或密码不正确,怎么办?

问题现象

通过Workbench工具远程连接Linux实例时提示“登录实例失败,原因:用户名或密码不正确”的错误。

问题原因

导致此问题的常见原因如下:

  • 复制粘贴或手动输入了错误的账号或密码。

  • Linux实例的SSH配置不允许root用户登录。

解决方案

请参考以下步骤进行排查:

  1. 如果确认您输入用户名和密码是错误的,可以通过重置实例密码的操作设置新密码,具体操作,请参见重置实例登录密码

  2. 如果确认您输入的root用户名和密码是正确的,则可能是SSH配置中未设置允许root用户登录。您可以通过以下任意一种方式进行处理:

Workbench远程连接问题(Windows)

通过Workbench远程连接Windows实例提示连接超时,怎么办?

问题现象

通过Workbench工具远程连接Windows实例时提示“登录主机:i-m5e****73a (47.*.*.157:3389) 失败,原因:链接超时!”错误。链接超时

问题原因

导致此问题的常见原因如下:

  • Windows实例的安全组设置不允许Workbench工具连接目标Windows实例。

  • 远程桌面RDP端口不是默认的3389端口。

  • Windows实例内的防火墙设置未允许Workbench工具连接目标Windows实例。

  • 第三方安全管理软件限制用户远程登录。

解决方案

请参考以下步骤进行排查:

  1. 查看目标Windows实例的RDP端口。具体操作,请参见查看ECS Windows远程桌面端口

    • 不是3389端口

      在Workbench工具中通过修改后的RDP端口重试远程连接。

    • 是3389端口

      请继续下一步检查。

  2. 查看目标Windows实例的安全组设置,检查SSH服务的端口是否放开。具体操作,请参见查询安全组规则

    说明
    • 此处的端口范围以RDP默认的端口3389为例。如果您修改过RDP默认端口,此处应当为您修改后的端口号。

    • 授权对象如果不是0.0.0.0/0,则需要同时对您需要访问的ECS实例的IP地址进行授权,此处47.96.60.0/24和118.31.243.0/24为例。

    规则方向

    授权策略

    优先级

    端口范围

    授权对象

    入方向

    允许

    1

    目的:3389/3389

    • 源:47.96.60.0/24和118.31.243.0/24

    • 源:0.0.0.0/0

  3. 检查Windows实例中是否开启防火墙,且不允许Workbench工具连接RDP端口。检查步骤如下:

    1. 通过阿里云VNC方式登录Windows实例。具体操作,请参见使用VNC登录实例

    2. 检查防火墙状态。

      • 已开启,请关闭防火墙,然后通过Workbench工具重试远程连接。

      • 未开启,请继续下一步检查。

  4. 检查Windows实例中是否安装第三方安全管理软件,例如安全狗等,并且通过该软件限制用户远程登录。

    • 第三方安全管理软件限制了远程登录

      请暂时关闭第三方安全管理软件对远程登录的限制,然后通过Workbench工具尝试远程连接。

    • 未通过第三方安全管理软件限制远程登录

      Windows实例中可能存在其他限制远程登录的系统设置,建议您选择阿里云VNC工具进行远程连接。具体操作。请参见使用VNC登录实例

通过Workbench远程连接Windows实例提示用户名或密码不正确,怎么办?

问题现象

通过Workbench工具远程连接Windows实例时提示“登录实例失败,原因:用户名或密码不正确”错误。

问题原因

导致此问题的常见原因如下:

  • 复制粘贴或手动输入了错误的账号或密码。

  • 远程登录用户不属于Remote Desktop Users组。

  • Windows实例的本地安全策略中被添加了拒绝用户远程登录的策略。

解决方案

请参考以下步骤进行排查:

  1. 检查您输入的用户名是否为Administrator。

    • 非Administrator用户

      Windows系统中远程桌面RDP默认的用户名为Administrator,如果您未修改过该用户名称,请尝试通过该用户名进行远程登录。

    • 是Administrator用户

      请继续下一步检查。

  2. 请确认您在Workbench中输入了正确的用户名和密码。

    • 输入错误

      手动输入用户名和密码时可能存在输入错误的情况,请检查您输入的用户名和密码,确认拼写正确。

      说明

      用户名Administrator拼写错误属于远程连接失败的常见原因之一。

    • 忘记密码

      请重置实例密码,然后使用新密码重新登录Windows实例。具体操作,请参见重置实例登录密码

    • 用户名和密码正确

      请继续下一步检查。

  3. 如果您曾经修改过Windows实例中的本地安全策略,请检查本地安全策略中是否添加了拒绝用户远程登录的策略。检查方法,请参见通过远程桌面连接Windows实例提示“远程桌面用户组没有该权限”错误怎么办?中的本地安全策略问题的解决方法章节。

    说明

    请先通过阿里云VNC方式登录Windows实例,然后再进行检查。具体操作,请参见通过密码认证登录Windows实例

    • 存在拒绝用户远程登录的策略

      在本地安全策略中移除被拒绝远程桌面登录的用户,然后重试远程连接。

    • 未修改过本地安全策略或者不存在拒绝用户远程登录的策略

      请继续下一步检查。

  4. 如果您使用非Administrator用户进行远程连接,请检查该用户是否属于Remote Desktop Users组。检查方法请参见通过远程桌面连接Windows实例提示“远程桌面用户组没有该权限”错误怎么办?中的普通用户未附加远程登录权限的解决方法章节。

    • 不属于Remote Desktop Users组

      将远程连接用户添加到Remote Desktop Users组,然后重试远程连接。

    • 属于Remote Desktop Users组

      Windows实例中可能存在其他限制远程登录的系统设置,建议您选择阿里云VNC工具进行远程连接。具体操作,请参见使用VNC登录实例

通过VNC远程连接问题

连接到控制台VNC后出现黑屏,怎么办?

连接到控制台VNC后出现黑屏,说明系统处于休眠状态。根据操作系统不同,执行不同的操作:

  • 如果是Linux实例,您可以按任意键激活该实例,进入登录界面。

  • 如果是Windows实例出现持续黑屏,您可以在界面左上角单击发送远程命令 > CTRL+ALT+DELETE,进入登录界面。

控制台VNC无法访问了,怎么办?

您可以通过浏览器进入控制台VNC界面排查问题。例如使用Chrome,在键盘上按F12键显示开发者工具,然后分析Console中显示的信息。

使用IE8.0,为什么无法使用控制台VNC?

仅支持IE10及以上版本的IE浏览器中使用控制台VNC,请下载最新版本的IE浏览器。

建议使用Chrome浏览器,阿里云的控制台对Chrome浏览器的兼容性更好。

使用Firefox浏览器打开控制台VNC会报错安全连接失败,怎么办?

可能您使用的Firefox版本没有共用的加密算法。

建议使用Chrome浏览器,阿里云的控制台对Chrome浏览器的兼容性更好。

使用VNC登录Windows实例后出现两个光标,怎么办?

如果您使用VNC登录Windows实例(实例规格族为g7、c7、r7)后出现两个光标,请按以下步骤修改鼠标相关设置:

  1. 修改控制面板中的鼠标设置。

    1. 打开控制面板,将查看方式切换为小图标,然后单击鼠标p267011

    2. 鼠标属性对话框中,单击指针选项页签,取消选中提高指针精确度,然后单击确定p267015

  2. 修改注册表中的鼠标设置。

    说明

    如果用户登录窗口未出现两个光标,则无需修改注册表配置,请跳过本步骤。

    1. 打开注册表编辑器。

    2. 在左侧导航栏,单击HKEY_USERS,然后在顶部菜单栏选择编辑 > 查找p267020

    3. 搜索关键字MouseSpeed,然后单击查找下一个p267023

    4. 双击注册表项MouseSpeed,将数值数据修改为0,然后单击确定p267024

  3. 重新使用VNC登录Windows实例。