为什么使用默认的端口(3389)无法登录Windows实例?

本文介绍使用默认的端口(3389)无法登录Windows实例的可能原因和解决方案

问题现象

通过远程桌面或Workbench等工具使用默认的端口(3389)无法登录Windows操作系统的ECS实例。

问题原因

该问题可能是由于Windows实例默认的远程桌面服务端口(3389)被修改导致。

说明

Windows实例远程桌面的默认端口为3389,基于安全性考虑,部分用户有修改默认端口的需求以减少通过远程桌面对ECS实例的恶意攻击和扫描次数。

解决方案

  1. 以VNC方式登录Windows实例。

    具体操作,请参见使用VNC登录实例

  2. 选择,输入regedit,打开注册表编辑器。

  3. 在注册表路径中输入HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp,按Enter键,然后查找PortNumber的值。

    如下图所示,PortNumber的值为3388,表示该ECS实例远程桌面服务端口为3388。

    • 如果该端口为您所需要的端口,登录实例时,端口请设置为PortNumber值。

    • 如果该端口不是您所需要的端口,请继续执行步骤4

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  4. 修改远程桌面服务端口。

    1. 右键单击PortNumber,然后单击修改(M)...

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    2. 在弹出的对话框中,基数选择十进制(D)数值数据(V)设置为您需要的端口号(如3389)。

      image.png

    3. 单击确定

  5. 重启该实例,使修改生效。

    具体操作,请参见重启实例

  6. 重新登录该实例。

    登录端口设置为步骤4中设置的端口,如果可以正常登录,表示该问题已解决。