如果您的站点是NS接入方式,需要转换为CNAME接入方式时,转换按钮不可用,可参考如下方法解决。
问题原因
该站点的服务区域为全球或中国内地,且DNS记录的代理状态为仅DNS,ESA不支持该种情况的站点转换成CNAME接入方式。
解决方法
可通过以下三种方法修改站点相关参数,然后再将NS接入方式转换为CNAME接入方式。
操作步骤
方法一:删除代理状态为仅DNS的记录
将代理状态为仅DNS的记录删除后,可进行接入方式转换的操作。为方便在新DNS服务商中添加记录,在删除代理状态为仅DNS的记录前,您可根据实际需要将仅DNS的记录进行备份。
在ESA控制台,选择站点管理,在站点列单击目标站点。
在左侧导航栏,选择 。
(可选)查找代理状态为仅DNS的记录,将相关信息进行备份。
单击操作列的删除,即可删除代理状态为仅DNS的记录。
方法二:修改代理状态
在记录界面中查找代理状态为仅DNS的记录,将其代理状态修改为代理加速,然后再将接入方式转换成CNAME接入。
在ESA控制台,选择站点管理,在站点列单击目标站点。
在左侧导航栏,选择 。
选择代理状态为仅DNS的记录,单击操作列的编辑。
打开代理状态开关,单击下一步。
选择网站加速类型后单击完成。
方法三:修改服务区域
将站点的服务区域修改为全球(不包含中国内地)后,可进行接入方式转换的操作。转换为CNAME接入方式后,您需根据自己的实际情况,评估是否将站点服务区域切换为原来的区域。
在ESA控制台,选择站点管理,单击站点名称或操作列的详情,进入站点概况界面。
在基本信息区域,单击区域:中国内地或区域:全球后的切换。
在弹出的对话框中选择全球(不包含中国内地),然后单击切换。
该文章对您有帮助吗?
- 本页导读
- 问题原因
- 解决方法
- 操作步骤
- 方法一:删除代理状态为仅DNS的记录
- 方法二:修改代理状态
- 方法三:修改服务区域