文档

升级流水线任务模板到自定义任务模板

更新时间:
一键部署

本教程介绍如何将流水线任务升级到自定义任务模板,从而使用ServerlessDevs 3.0进行发布。

说明

当您部署时遇到如下错误时,可以通过本教程进行操作。

WARNING:======================

* Please check the edition field of s.yaml, you can specify it as 1.0.0 or 2.0.0.

Message: The edition field in the s.yaml file is incorrect

说明

如果您的应用是在2023年11月4号之前创建的,默认流水线不支持ServerlessDevs 3.0,您需要关注本教程来完成升级。

在2023年11月4号之后创建的应用,默认流水线支持了ServerlessDevs 3.0,您无需关注本教程。

当您的流水线任务模板使用了plan-task、deploy-task、canary-task、release-task时,这些任务模板底层实现不支持ServerlessDevs 3.0 YAML规范。当您升级s.yaml为3.0版本后,需要将这些流水线任务修改成自定义任务模板,才可以使用ServerlessDevs 3.0进行发布。

您可以通过函数计算控制台,找到应用,在流水线管理页签的流水线详情区域查看当前流水线的配置,如下图中①②③④⑤所示,查看流水线YAML的taskTemplate,如果taskTemplate是以上列举的4个中的任意一个任务,则需要替换为serverless-runner-task。

image.png

具体修改方法如下:

  • plan-task:代码检查(下图①)-> 前置检查(下图②)-> 替换右侧Yaml(下图③)-> 保存(下图④)

image.png

  • deploy-task:构建(下图①)-> 构建部署(下图②)-> 替换右侧Yaml(下图③)-> 保存(下图④)

image.png

  • canary-task(当您主动开启时才需要关注,默认情况不需要修改):部署(下图①)->版本灰度(下图②)-> 替换右侧Yaml(下图③)-> 保存(下图④)

image.png

  • release-task(当您主动开启时才需要关注,默认情况不需要修改):部署(下图①)->版本发布(下图②)-> 替换右侧Yaml(下图③)-> 保存(下图④)

image.png

  • 本页导读 (1)