镜像失败时如何修复?

本文介绍在云盘异步复制过程中,遇到启动复制或启动容灾演练时提示ECS引导镜像失败时,如何进行修复。如果您曾手动修改过引导镜像,并在容灾演练或故障切换后遇到无法进入操作系统的问题,也可参考本文的解决方案。

  • 问题现象

    在尝试开始数据复制或是预览容灾演练方案时,系统将会提示引导镜像错误。如下图所示:

    image

  • 原因分析

    在启动复制时,HDR首先会在容灾站点上利用代理镜像创建对应的容灾ECS实例。随后,它将从主站点复制数据到新创建的ECS上,并在复制周期结束后生成或更新恢复点。当执行容灾演练时,HDR会基于代理镜像在容灾环境中创建一个用于演练的ECS,并采用最新的恢复点来替换其内容。

    由于HDR不直接干预操作系统的内部运作,如果生产环境中的ECS镜像因为升级、下线或删除等原因变得不可用,HDR可能无法准确地识别ECS的启动模式及操作系统版本信息。这可能导致在实际进行容灾切换或是容灾演练过程中,目标端的ECS无法正常启动。有关启动模式的最佳实践,可参考ECS实例启动模式最佳实践

  • 解决方法

    • 自动修复

      在预览时,如果系统提示镜像存在问题,您可以通过单击查看详情来获取更多信息。

      image

      在弹出的详情对话框中,您可以为一台或多台ECS实例选择合适的可用镜像进行配置。HDR功能结合了云助手服务,提供了一键修复功能,您可通过单击修复进行自动修复。该功能会自动运行脚本来检测ECS实例的启动模式、操作系统及其版本等关键信息,并据此智能匹配合适的可用引导镜像。您可以在云助手控制台中查看所有执行操作的具体细节。

      image

    • image

    • 手动修复

      如果自动修复功能未能找到合适的镜像,您可以登录ECS系统确认启动模式和操作系统版本。随后,根据实际情况修改ECS引导镜像,并继续进行复制或容灾演练。