问题现象
应用通过阿里云容器服务ACK接入MSE微服务治理,可能出现以下几种现象:
MSE无相关的应用实例信息。
MSE有相关应用实例名称,但实例数为0。
应用可以正常接入MSE,实例数目显示正常,但服务详情页面缺少服务元数据等相关信息。
可能原因
造成容器服务ACK应用接入MSE失败的可能原因如下:
接入操作错误。
接入MSE的应用版本不支持。
解决方案
检查接入的MSE应用框架是否在系统支持范围内,Spring Cloud应用当前仅支持Edgware及之后版本。相关内容,请参见使用限制。
通过应用运行日志检查应用是否正常启动或调用。
登录容器服务管理控制台。
在控制台左侧导航栏中,单击集群。
在集群列表页面中,单击目标集群名称或者目标集群右侧操作列下的详情。
在集群管理页左侧导航栏中,选择 。
在无状态页面中,单击目标应用名称,在日志页签下查看日志详情。
说明显示行数选择最大条目数500行,查看全部日志信息。
上述操作排查后若均无异常,再检查应用是否正常挂载探针。可通过排查脚本在问题应用终端执行并获得诊断结果。
wget -O - https://edas-public.oss-cn-hangzhou.aliyuncs.com/oneAgent/service_metadata_diagnosis.sh | sh -s
如果未显示Java Agent版本号信息,表示应用未正常挂载探针,请检查应用所在命名空间是否已开启微服务治理。相关操作,请参见ACK微服务应用接入MSE治理中心
如果显示没有相关文件,可能是应用没有正常挂载探针启动导致缺失日志文件,请检查应用YAML文件相关配置信息是否正常。
如果显示正常,但输出内容显示服务已上报0条记录,请检查应用框架是否在MSE支持范围内。
如果上述操作都执行但仍未解决问题,请提交工单联系我们。
请在工单描述中提供以下信息:
用户ID
地域(例如:上海)
产品类型(例如:MSE或EDAS)
问题描述
应用启动的完整日志
脚本排查后的诊断结果
集群KubeConfig(非必需),获取方式,请参见生成临时的KubeConfig。
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