当您通过HTTPS访问OSS出现证书异常时,可以参考本文所示方法排查处理。
证书未配置
问题现象
浏览器打开链接报“您的连接不是私密连接”,报错信息:NET::ERR_SSL_PROTOCOL_ERROR。
问题原因
域名未配置HTTPS证书,可以通过telnet命令测试443端口的连通性,无法连接代表证书未配置。
解决办法
登录OSS控制台上传证书。具体操作,请参见通过HTTPS协议访问OSS。
证书过期
问题现象
浏览器打开链接报“您的连接不是私密连接”,报错信息:NET::ERR_CERT_DATE_INVALID。
问题原因
域名绑定的证书已过期,过期时间可以通过浏览器查看。
浏览器地址栏左侧会显示不安全标识,单击后安全信息面板中出现证书无效条目,打开证书详情可查看有效期的颁发日期和截止日期。
解决办法
前置排查:在检查证书前,请先确认 OSS Bucket 无欠费。欠费同样会导致 HTTPS 访问异常,症状与证书过期相似但根因不同。
如果自定义域名已开启 CDN 加速,HTTPS 证书由 CDN 管理,需要在CDN 控制台操作,而非 OSS 控制台。请根据访问方式,选择以下对应的处理步骤。
场景一:域名直连 OSS(未开启 CDN 加速)
-
重新申请证书。
阿里云支持个人测试证书(免费版)。更多信息,请参见个人测试证书说明。
-
登录OSS控制台上传证书。具体操作,请参见通过HTTPS协议访问OSS。
场景二:域名已开启 CDN 加速
登录CDN 控制台,在域名管理页面查看证书状态并更新证书。具体操作,请参见查询域名证书和配置 HTTPS 证书。
证书不匹配
问题现象
浏览器打开链接报“您的连接不是私密连接”,报错信息:NET::ERR_CERT_COMMON_NAME_INVALID。
查看证书详情,证书链层级为 GlobalSign Root CA → GlobalSign Organization Validation CA - SHA256 - G2 → *.oss-cn-hangzhou.aliyuncs.com,证书状态显示为有效。
问题原因
访问URL中的域名配置的证书范围没有包含当前域名。比如:访问的URL为https://example.aliyun.com/object,配置的证书指向的域名为:*.oss-cn-hangzhou.aliyuncs.com。
解决办法
登录OSS控制台上传证书。具体操作,请参见通过HTTPS协议访问OSS。