文档

2023年4月27日起PolarDB PostgreSQL版(兼容Oracle)部分插件在低内核版本限制创建

更新时间:

PolarDB PostgreSQL版(兼容Oracle)支持插件策略调整,将于2023年4月27日起,部分插件在指定内核小版本才能创建,具体请参见限制插件,已创建的插件使用不受影响。

背景信息

为了规范插件管理,提升PolarDB PostgreSQL版(兼容Oracle)在插件侧的安全防护,本次对部分插件进行了优化:若集群的内核小版本低于指定版本,将不再支持新创建这部分插件,如需使用,需要将内核小版本升级到指定版本或以上版本。

限制生效时间

2023年04月27日

涉及版本

PolarDB PostgreSQL版(兼容Oracle)

限制插件

内核小版本范围

限制插件

Oracle语法兼容1.0

V1.1.31版本前(不包括V1.1.31

pg_cron、cube、earthdistance、ganos_raster、ganos_geometry_sfcgal、ganos_geometry_topology、ganos_geometry、ganos_networking、ganos_spatialref、ganos_pointcloud_geometry、ganos_pointcloud、ganos_trajectory、ganos_geomgrid、ganos_geometry_pyramid、ganos_fdw、postgis、postgis_sfcgal、postgis_topology、postgis_tiger_geocoder、address_standardizer_data_us、encdb、index_advisor、pg_wait_sampling、pldbgapi、polar_tz_offset、dbms_job、fastann、polar_monitor、pase、polar_outline、plv8、pg_bigm、hypopg、zombodb、polar_anydata、polar_nvl、polar_nvl2、polar_from_tz、polar_dba_views、polar_to_char、polar_utility、polar_resource_group

Oracle语法兼容2.0

V2.0.14.6.0版本前(不包括V2.0.14.6.0)

hypopg、pg_bigm、polar_monitor、zhparser、earthdistance、ganos_raster、ganos_geometry_sfcgal、ganos_geometry_topology、ganos_geometry、ganos_networking、ganos_spatialref、ganos_pointcloud_geometry、ganos_pointcloud、ganos_trajectory、ganos_geomgrid、ganos_geometry_pyramid、ganos_fdw

除上述范围之外的版本

不限制插件创建。

影响

  • 如果您已创建上述列举的限制插件,且未删除插件,则使用不受影响。

  • 如果您未创建过上述列举的限制插件,或创建过但已删除,且集群内核小版本在限制插件的内核小版本范围内,则无法再新创建上述限制插件。如需创建,请将内核小版本升级至不限制插件创建的版本。

相关参考

查询和升级内核小版本,请参见版本管理