文档

添加 SDK 依赖

更新时间:
一键部署

本节主要是介绍产品 SDK 以及核心库 SDK 的依赖方式。

云产品的升级版 SDK 依赖信息

以云产品 ECS 的升级版 SDK 的为例,引入产品 SDK 依赖的方式如下:

  1. 使用 .NET CLI 的方式,可以通过 --version 指定版本。

dotnet add package AlibabaCloud.SDK.Ecs20140526

# 指定版本
dotnet add package AlibabaCloud.SDK.Ecs20140526 --version 2.1.0

2. 使用 Package Manager 方式,可以通过 -Version 指定版本。

Install-Package AlibabaCloud.SDK.Ecs20140526

# 指定版本
Install-Package AlibabaCloud.SDK.Ecs20140526 -Version 2.1.0

从中可以看出升级版 SDK 的命名方式为AlibabaCloud.SDK.${产品名}${OpenAPI 版本号}的方式命名。开发者也可以通过SDK信息中心来查看具体产品的原版 SDK 的信息以及其他依赖方式。

不再需要 SDK 核心依赖

产品的升级版 SDK 中包含了接口参数处理,请求组装以及返回值处理等 OpenAPI 请求的主要逻辑,摆脱了对 SDK Core 的依赖,只需要将一些通用的处理抽象出公共的函数封装成模块即可,开发者可以只关注本身的 SDK 包依赖即可,也可以通过依赖以下模块来使用最新的依赖:

dotnet add package AlibabaCloud.OpenApiClient
重要

建议尽量用最新版,因为每一版的发布都是对过往漏洞的解决和更新。

  • 本页导读 (1)
文档反馈