本文主要介绍迁移在SMC迁移时,迁移任务出错提示“Customer.Client.Network.SyncConnectFailed”的原因及解决方案。
问题描述
在SMC迁移时,迁移任务出错提示“Customer.Client.Network.SyncConnectFailed”。
问题原因
源系统SMC客户端进行数据同步时网络连接失败,可能原因有:
目标实例指中转实例或目标实例,您可以在迁移任务详情页找到迁移中转实例ID或目标实例ID。
目标实例的数据同步端口(8703端口)异常。
源服务器到目标实例的
IP:8703
端口网络访问不通。
解决方案
检查目标实例的8703端口网络访问是否正常。
访问ECS控制台-实例。
在页面左侧顶部,选择目标资源所在的资源组和地域。
确认目标实例是否为正常运行的状态。
如果目标实例为运行中,则直接执行下一步。
如果实例已停机,则需要启动实例后继续执行下一步。
如果实例已释放,则需重建迁移任务。具体操作,请参见服务器迁移至云服务器ECS。
单击目标实例的实例ID进入实例详情页,在定时与自动化任务页签,单击发送命令。
Windows系统:在命令内容中输入
netstat -ano | findstr 8703
,单击立即执行。Linux系统:在命令内容中输入
netstat -ano | grep 8703
,单击立即执行。
如果执行成功并有8703相关内容输出,则表示目标实例内8703端口正常。
检查目标实例的安全组的入方向是否已放开8703端口,或者是否有其他安全组规则冲突限制。
说明默认情况下SMC迁移任务会自动给目标实例关联一个临时安全组,在目标实例的入方向放开8703端口。
检查源系统网络服务是否正常。
检查系统本地网络服务是否正常,检查hosts、DNS等配置是否正常。
迁移任务默认使用公网模式传输,需要确保源系统可访问公网。
如果迁移任务选择了私网模式传输,则需要确保源系统到目标VPC/交换机的私网已打通。具体操作,请参见私网传输迁移。
说明如果不清楚是否打通私网,一般情况下建议选择公网模式传输,如果错选了私网模式可重新选择公网模式后再试。
检测源系统到目标实例的网络访问是否正常。
放开目标实例的安全组的入方向ICMP协议,使用ping命令测试源服务器到目标实例的网络是否正常。
如果不通,则需要排查本地网络配置或中间网络设备,如防火墙或代理的出方向是否有IP访问限制。
使用
telnet
命令测试到目标实例8703端口是否连通,如果不通,需要排查本地网络配置或中间网络设备,如防火墙或代理出方向是否有IP端口访问限制。检查是否开启了阿里云云防火墙,是否配置了访问控制策略导致网络访问被拦截。例如互联网边界防火墙、VPC边界防火墙等。具体操作,请参见互联网边界防火墙。
若迁移任务使用公网模式传输,且传输模式为块复制,默认使用SSL进行安全数据传输。若源系统不支持或限制使用SSL,请使用修改迁移功能,关闭开启SSL加密传输。
问题排查解决后,您可运行SMC客户端进行验证。