出错提示S2磁盘分区文件数据同步出错

更新时间:
复制为 MD 格式

本文主要介绍在使用SMC迁移时,迁移任务出错提示“S2_* 磁盘分区文件数据同步出错”的问题描述、问题原因及其解决方案。

问题描述

SMC迁移时,迁移任务出错提示“S2_* 磁盘分区文件数据同步出错”。其中S2_*可能的错误码如下:

  • S2_R255

  • S2_R11

  • S2_R1

  • S2_R12

  • S2_R70

问题原因

源系统SMC客户端进行磁盘分区文件级别的数据同步时出错,可能原因有:

  • S2_R255:源系统到目标实例的IP:8703端口网络连接不通。

  • S2_R11:迁移任务设置的目标磁盘分区大小小于源系统磁盘分区实际数据量,目标分区空间不足导致。

  • S2_R1:源系统安装的Rsync版本为3.0.6以下或者不支持ACLs能力。

  • S2_R12:源系统到目标实例的IP:8703端口网络中断。

  • S2_R70:源系统磁盘分区文件数据同步卡住,导致迁移任务超时。

解决方案

不同的错误码对应的解决方案如下:

  • S2_R255

    检查源系统到目标实例的IP:8703端口网络访问是否正常。

    1. 检查目标实例的安全组端口是否已放开入方向的8703端口,或者是否有其他安全组规则冲突限制。

      说明

      默认情况下SMC任务会自动给目标实例关联一个临时安全组,来放开目标实例的入方向8703端口。

    2. 使用telnet命令测试到目标实例8703端口是否连通,如果不通,需要排查本地网络配置或中间网络设备,如防火墙或代理出方向是否有IP端口访问限制。

    3. 检查是否开启了阿里云云防火墙,是否配置了访问控制策略导致网络访问被拦截。例如互联网边界防火墙、VPC边界防火墙等。具体操作,请参见防火墙开关

  • S2_R11

    检查迁移任务目标磁盘分区大小是否小于源系统磁盘分区实际数据量,如果小于,则需要重建迁移任务并设置合适的磁盘分区大小后再试。

  • S2_R1

    使用rsync --version检查源系统rsync版本。

    建议rsync3.0.6及以上版本,最新版本是3.1.3,同时检查是否支持ACLs能力,如果没有ACLs则表示不支持,此时需要重装rsync后再试。

    rsync  version 3.1.2  protocol version 31
    Copyright (C) 1996-2015 by Andrew Tridgell, Wayne Davison, and others.
    Web site: http://rsync.samba.org/
    Capabilities:
        64-bit files, 64-bit inums, 64-bit timestamps, 64-bit long ints,
        socketpairs, hardlinks, symlinks, IPv6, batchfiles, inplace,
        append, ACLs, xattrs, iconv, symtimes, prealloc
    rsync comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
    are welcome to redistribute it under certain conditions.  See the GNU
    General Public Licence for details.
  • S2_R12

    检查源系统到目标实例的IP:8703端口网络是否正常稳定,迁移过程中不要中断网络,待网络正常后再试。

  • S2_R70

    • 检查源系统到目标实例的IP:8703端口网络是否正常稳定,源系统带宽速度是否足够,防止因网络带宽过小导致的传输进度过慢而超时。

    • 检查源系统磁盘分区是否存在以下情况并处理:

      • 动态变化的大文件,如数据库数据文件或日志文件。

        • 可以考虑在合适的时间点暂停相关数据业务服务,确保迁移的过程中大文件不再动态变化后再试。

        • 使用过滤配置排除相关目录后再试,具体操作,请参见如何过滤、排除不需要迁移的文件或目录?。对于未迁移的文件或目录,后续可考虑用其他方案迁移。

      • 大量小文件,如分布式文件系统海量数据、文件服务器等。

        使用过滤配置排除相关目录后再试,具体操作,请参见如何过滤、排除不需要迁移的文件或目录?。对于未迁移的文件或目录,后续可考虑用其他方案迁移。

问题排查解决后,运行SMC客户端再试。具体操作,请参见管理SMC客户端