文档

安装表格存储Java SDK

更新时间:

安装表格存储Java SDK后,即可在编写代码时调用表格存储SDK的接口。本文介绍如何安装表格存储Java SDK。

环境准备

  • 安装表格存储Java SDK需使用JDK 6及以上版本。

  • 已安装Java开发工具,例如IntelliJ IDEA、Eclipse等。

安装方式

重要

使用Java SDK时,如果出现了java.lang.ExceptionInInitializerError等错误,则可能是项目中存在PB库冲突。如何解决PB库冲突,请参见使用Java SDK时出现PB库冲突

您可以通过以下两种方式安装表格存储Java SDK。

在Maven项目中加入依赖项

在Maven工程中使用表格存储Java SDK,只需在pom.xml中加入相应依赖即可。以5.16.0版本为例,在<dependencies>内加入如下内容:

说明

关于Java SDK历史迭代版本的更多信息,请参见Java SDK历史迭代版本

<dependency>
    <groupId>com.aliyun.openservices</groupId>
    <artifactId>tablestore</artifactId>
    <version>5.16.0</version>
</dependency>                 

在Eclipse中导入JAR包

以5.16.0版本为例,详细步骤如下:

  1. 下载Java SDK开发包

  2. 解压该开发包。

  3. 解压后将文件夹中的文件tablestore-<versionId>.jar以及lib文件夹下的所有文件拷贝到您的项目中。

  4. 其中<versionId>表示表格存储Java SDK的版本,例如5.16.0版本的文件名称为tablestore-5.16.0.jar。

  5. 在Eclipse中选择您的工程,右键选择Properties > Java Build Path > Add JARs

  6. 选中您在第3步拷贝的所有JAR文件。

示例程序

表格存储Java SDK提供丰富的示例程序,方便参考或直接使用。您可以解压下载好的SDK包,在examples文件夹中查看示例程序。具体下载路径请参见表格存储Java SDKGitHub地址

  • 本页导读 (1)