使用Nginx进行访问网页出现“502”和“connect upstream time out”报错
问题描述
使用Nginx进行访问网页出现“502”报错,但是存在PHP-FPM进程而且错误日志(error_log)里无任何错误,从Nginx网页看到出现以下报错。
connect upstream time out
问题原因
PHP-FPM设置监听127.0.0.1:9000
端口,但是本地网卡(lo)未启动。
解决方案
阿里云提醒您:
- 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
- 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
- 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。
您可以使用ifup ifcfg-lo
命令启动本地网卡(lo),并将其设置为开机启动,关于如何设置网卡开机自启,请参见更多信息。
更多信息
- 请您使用以下命令编辑本地网卡(lo)配置文件。
vim /etc/sysconfig/network-script/ifcfg-lo
- 将ONBOOT=no改为yes保存退出,并使用
systemctl restart network
重启网络。
适用于
- 云服务器ECS
- 轻量应用服务器