阿里云 E-MapReduce SDK 包含阿里云 Java SDK 公共部分和 E-MapReduce 部分,公共部分依赖 aliyun-java-sdk-core, E-MapReduce 部分依赖 aliyun-java-sdk-emr。我们推荐您采用 Maven 的方式来管理您的工程。

Maven 依赖

<dependency>
          <groupId>com.aliyun</groupId>
          <artifactId>aliyun-java-sdk-core</artifactId>
          <version>2.3.9</version>
     </dependency>
     <dependency>
          <groupId>com.aliyun</groupId>
          <artifactId>aliyun-java-sdk-emr</artifactId>
          <version>2.2.2</version>
      </dependency>

下载地址

aliyun-java-sdk-core-2.3.9.jar

aliyun-java-sdk-emr-2.2.2.jar