Linux操作系统云虚拟主机提供更换PHP版本的功能,您可以根据网站程序对PHP版本的要求,选择合适的PHP版本。

使用限制

Linux操作系统云虚拟主机支持PHP 8.0及以下版本,但是根据产品类型不同,云虚拟主机支持的PHP版本也有所不同,具体说明如下:

  • 增强版云虚拟主机支持PHP 8.0及以下版本。
  • 非增强版云虚拟主机部分支持PHP 7.4和PHP 8.0版本,请以云虚拟主机控制台界面显示为准。

操作步骤

  1. 登录云虚拟主机管理页面
  2. 找到待更换PHP版本的云虚拟主机,单击对应操作列的管理
  3. 在左侧导航栏,选择高级环境设置 > PHP版本设置
  4. PHP版本设置页面,选择PHP版本,单击保存设置
    以Linux操作系统独享虚拟主机基础增强版为例,如下图所示:linux-独享虚拟主机基础增强版-PHP切换
  5. 在弹出的提示对话框,单击确认
    确认更换PHP版本

执行结果

PHP版本切换设置完成后,页面上方会弹出提示设置成功的消息框。PHP版本切换生效需要5分钟左右,在此期间,您的网站程序依然运行在原版本下。