Change process error codes

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When you change an application in an Elastic Compute Service (ECS) cluster using the Enterprise Distributed Application Service (EDAS) console, a change record is generated. This topic describes the error messages and error codes that can occur during the change process.

EDAS-10000

  • Error message

    EDAS-10000 NO_SPACE_LEFT_ON_DISK

  • Possible cause

    The disk space is full.

  • Solution

    Log on to the ECS instance and delete the logs.

EDAS-10001

  • Error message

    EDAS-10001 STAR_AGENT_OFFLINE

  • Possible cause

    StarAgent is offline.

  • Solution

    Log on to the ECS instance and run the sh /home/staragent/bin/staragentctl restart command to restart the agent.

EDAS-10002

  • Error message

    EDAS-10002 Task timeout during execution

  • Possible cause

    The task execution timed out.

EDAS-10012

  • Error message

    EDAS-10012 UNZIP_WAR_FAILED

  • Possible cause

    The unzip command failed to decompress the WAR package.

  • Solution

    Verify that your WAR package can be decompressed.

EDAS-10013

  • Error message

    EDAS-10013 JAR_WAR_FAILED

  • Possible cause

    The JAR command failed to decompress the WAR package. This may be because the Java Development Kit (JDK) is installed incorrectly, or the JDK version in the operating system does not include the JAR command.

  • Solution

    Log on to the application's ECS instance as the root user. Run the yum install -y java-1.8.0-openjdk-devel or yum install -y java-1.7.0-openjdk-devel command based on your JDK version. Ensure that the ECS instance can connect to the internet.

EDAS-10014

  • Error message

    EDAS-10014 WAR_URL_403

  • Possible cause

    The WAR package failed to download because you do not have the required access permissions.

EDAS-10015

  • Error message

    EDAS-10015 WAR_URL_404

  • Possible causes

    The WAR package failed to download because the package was not found.

EDAS-10016

  • Error message

    EDAS-10016 JAVA_PROCESS_ROOT

  • Possible cause

    The application failed to stop because the application process was started by the root user, and EDAS does not have permission to stop it.

  • Solution

    Stop the application process manually as the root user. Then, retry the operation.

EDAS-10017

  • Error message

    EDAS-10017 HOME_ADMIN_FILE_ROOT

  • Possible cause

    The application failed to start because the tomcat directory or the application directory contains a file or directory with root permissions.

  • Solution

    Check the /home/admin/app and /home/admin/${tomcat-path} directories for files or directories that have root permissions. Change the owner of these files or directories to the `admin` user. Then, retry the operation.

EDAS-10020

  • Error message

    EDAS-10020 SLB_NOT_ENOUGH_BALANCE

  • Possible cause

    Binding the SLB instance failed.

  • Solution

    Your account must have a balance of at least CNY 100 to purchase an SLB instance.

EDAS-10021

  • Error message

    EDAS-10021 SLB_BIND_ALREADY_HAVE_SERVICE

  • Possible cause

    The SLB instance failed to bind because the application is already bound to an SLB instance.

  • Solution

    First, unbind the existing SLB instance in the console. Then, bind the target SLB instance.

EDAS-10022

  • Error message

    EDAS-10022 K8s_READINESS_ERROR

  • Possible cause

    The application failed to start because the readiness check failed to pass within the specified time.

  • Solution

    Verify that the configurations are correct.

EDAS-10023

  • Error message

    EDAS-10023 K8s_BACKOFF_RESTART

  • Possible cause

    The application failed to start.

  • Solution

    Check for any issues.

EDAS-10024

  • Error message

    EDAS-10024 K8s_LIVENESS_ERROR

  • Possible cause

    The application failed to start because the liveness check failed to pass within the specified time.

  • Solution

    Verify that the configurations are correct.

EDAS-10025

  • Error message

    EDAS-10025 PORT_CHECK_TIMEOUT

  • Possible cause

    The port check timed out when the application started. The timeout period is typically 5 minutes, and the port did not open within this time.

  • Solution

    1. On the application details page for the ECS instance, find the Application Port in the Application Settings section.查看应用端口

    2. Log on to the ECS instance. Run one of the following commands to check if the port is open.

      • Method 1:

        netstat -lnp | grep <port_number>
      • Method 2:

        ss -lnp | grep <port_number>
    3. If the port is not open, check the application startup log for errors. Resolve any errors based on the information provided in the log.

EDAS-10026

  • Error message

    EDAS-10026 URL_CHECK_TIMEOUT

  • Possible cause

    This error occurs if a URL health check times out when the application starts. The timeout period is 30 minutes. A health check passes only if the curl $URL command returns an HTTP status code of 200.

  • Solution

    Log on to the ECS instance. Run the curl -v $URL command to check whether the configured application URL is accessible. If it is not accessible, check the application logs to determine whether the application process failed to start.

EDAS-10027

  • Error message

    EDAS-10027 STARAGENT_CMD_EXECUTE_TIMEOUT

  • Possible cause

    A command timed out during deployment. The timeout period is 60 seconds. This error occurs if a command does not finish within this period.

  • Solution

    • Retry the failed task in the EDAS console.

    • If the issue persists after you retry, join the DingTalk group (ID: 31723701) to contact product technical experts for assistance.

EDAS-10028

  • Error message

    EDAS-10028 PULL_WAR_TIMEOUT

  • Possible cause

    This error occurs if the WAR/JAR package pull times out. This can happen when you deploy from a custom URL. The timeout period is 5 minutes.

  • Solution

    Confirm that the URL is correct. Log on to the ECS instance and run the wget command to download from the URL. Check whether the download finishes within 5 minutes.