When a migration task in Server Migration Center (SMC) fails with the error "Client.Snapshot.CreateFailed", the SMC client cannot create a disk partition snapshot on the source system. This topic explains why this happens and how to fix it.
Symptoms
During a migration in Server Migration Center (SMC), a migration task fails with the error message "Client.Snapshot.CreateFailed".
Causes
During block replication, the SMC client creates a snapshot device for each disk partition on the source system to synchronize data. This error occurs when snapshot creation fails. Possible reasons vary by operating system:
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Windows:
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Insufficient space on the disk partition.
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Third-party security or antivirus software is installed.
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The Volume Shadow Copy storage usage limit for the disk partition is too low.
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The Volume Shadow Copy service is not working correctly.
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Linux
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Insufficient space on the disk partition.
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The available system memory is less than 300 MB.
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The snapshot device for the disk partition is not working correctly.
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Solutions
Choose the solution based on the operating system of the source system.
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Windows
Open Event Viewer and check for errors related to vss, volsnap, or disk. Then resolve any errors you find.
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If the error indicates insufficient disk space or that a Volume Shadow Copy snapshot cannot grow:
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Check the free space on the disk partition. Make sure at least 10% to 15% of the total space is available.
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Check whether the storage usage limit for the volume is too low. If so, increase the limit or remove it, and then try again. To adjust the limit, open the Local Disk (C:) Properties dialog box, and select the Shadow Copies tab. Select the C:\ volume and click Settings.... In the Settings dialog box, for Maximum size, select Use limit and set the value to 4095 MB. Click OK.
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If you receive an "access denied" error with error code 0x80070005, third-party security or antivirus software may be blocking the operation. Grant disk backup permissions or disable the software, and then try again.
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Verify that the Volume Shadow Copy service is running correctly.
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Linux
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Check whether the
/dev/smcss9device exists, and rundmesg | grep smcssto check for errors.-
Ensure that at least 300 MB of system memory is available.
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Check the free space on the disk partition. Make sure at least 10% to 15% of the total space is available.
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In the SMC client installation directory, run
./Check/client_check --ssclear smcssto clear residual snapshot devices, and then try again. For details on finding the installation directory, see View the SMC client.
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If the error message contains "io scheduler not support", change the I/O scheduler for the affected disk.
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Identify the index of the problematic disk.
Find the msg field in the error message, for example,
msg=CreateSnapshot 0-x Failed. In this example,0-xindicates the first disk,1-xindicates the second disk,2-xindicates the third disk, and so on. -
Use the disk index from the previous step to find the disk device name.
Run
lsblkto find the corresponding disk device name. The index starts from 0.In the command output, index 0 corresponds to the disk device vda (the 40 GB system disk), and index 1 corresponds to the disk device vdb (the 100 GB data disk).
# lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT vda 253:0 0 40G 0 disk ├─vda1 253:1 0 2M 0 part ├─vda2 253:2 0 200M 0 part /boot/efi └─vda3 253:3 0 39.8G 0 part / vdb 253:16 0 100G 0 disk └─vdb1 253:17 0 100G 0 part /data -
Use the disk name from the previous step to view the I/O scheduler used by the disk.
For example, to view the I/O scheduler for vdb, run
cat /sys/block/vdb/queue/scheduler.The brackets
[]indicate the active I/O scheduler. In this example, the active scheduler is bfq.cat /sys/block/vdb/queue/scheduler mq-deadline kyber [bfq] noneNoteThe output lists all available I/O schedulers: mq-deadline, kyber, bfq, and none.
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Change the I/O scheduler from bfq to another available scheduler.
For example, to switch to mq-deadline:
Run
sudo echo mq-deadline > /sys/block/vdb/queue/scheduler.Then run
cat /sys/block/vdb/queue/schedulerto verify the change.cat /sys/block/vdb/queue/scheduler [mq-deadline] kyber bfq noneIn the output,
[mq-deadline]indicates that mq-deadline is the active I/O scheduler.
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After you resolve the issue, run the SMC client again to verify the result.