This topic describes the symptoms, causes, and solutions to the "S6_* Failed to create a disk partition snapshot" error that occurs during a Server Migration Center (SMC) migration job.
Symptoms
A Server Migration Center (SMC) migration job fails and returns an error message such as "S6_* Failed to create a disk partition snapshot". Possible S6_* error codes include the following:
S6_8
S6_1
Causes
During block replication, the SMC client automatically creates a snapshot device for a disk partition on the source server to synchronize data. This error occurs if the SMC client fails to create the snapshot. The causes vary depending on the source server's operating system:
Windows:
Insufficient space on the disk partition.
Third-party security or antivirus software is installed.
The storage limit for Volume Shadow Copy is insufficient.
The Volume Shadow Copy Service is not working correctly.
Linux
Insufficient space on the disk partition.
Available memory is less than 300 MB.
The snapshot device for the disk partition is not working correctly.
Solutions
The solution varies depending on the operating system of the source server:
Windows
Open Event Viewer and check for errors from sources such as
vss,volsnap, ordisk. Resolve the issues as indicated by the error messages.If the error indicates insufficient disk space or that the VSS shadow copy cannot be extended:
Ensure the disk partition has enough free space. We recommend reserving at least 10% to 15% of the total space.
Check if the storage limit for Volume Shadow Copy is too small. Increase the limit or remove it, and then try again.
Open the disk Properties dialog box, select the Shadow Copies tab, choose the target volume, and then click Settings.... In the Maximum size area, select No limit or increase the Use limit value (for example, to 4095 MB), and then click OK.
If an 'Access is denied' error occurs with the error code
0x80070005, check for third-party security or antivirus software. Grant the required disk backup permissions or temporarily disable the software, and then retry the operation.Ensure the Volume Shadow Copy Service is running correctly.
Linux
Check if the
/dev/smcss9device exists, and run thedmesg | grep smcsscommand to check for related errors.Ensure the system has at least 300 MB of available memory.
Ensure the disk partition has enough free space. We recommend reserving at least 10% to 15% of the total space.
In the SMC client installation directory, run the
./Check/client_check --ssclear smcsscommand to clear any residual snapshot devices, and then try again. To find the SMC client installation directory, see View and run the SMC client.
(Conditional) If the error message contains "io scheduler not support", change the disk's I/O scheduler by following these steps.
Identify the index of the affected disk.
Find the
msgpart of the error message. For example, inmsg=CreateSnapshot 0-x Failed,0-xindicates the first disk,1-xindicates the second disk, and so on.Use the index from step i to find the corresponding disk device name.
Run the
lsblkcommand to identify the disk device name for the index. Indexes start from 0.[root@xxx ~]# lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT vda 253:0 0 40G 0 disk # Disk index 0 ├─vda1 253:1 0 2M 0 part ├─vda2 253:2 0 200M 0 part /boot/efi └─vda3 253:3 0 39.8G 0 part / vdb 253:16 0 100G 0 disk # Disk index 1 └─vdb1 253:17 0 100G 0 part /dataUse the disk name from step ii to check the disk's current I/O scheduler.
For example, for disk vdb, run the
cat /sys/block/vdb/queue/schedulercommand to view its I/O scheduler.In the output, the scheduler in brackets (
[]) is the current scheduler.mq-deadline kyber [bfq] noneNoteThe output lists all available I/O schedulers: mq-deadline, kyber, bfq, and none.
Replace the current scheduler (
bfq) with a different scheduler.Use any scheduler other than
bfq. For example, to switch tomq-deadline:Run the command
sudo echo mq-deadline > /sys/block/vdb/queue/scheduler.Run the
cat /sys/block/vdb/queue/schedulercommand again to confirm the change. The output shows that the scheduler is changed frombfqtomq-deadline.sudo echo mq-deadline > /sys/block/vdb/queue/scheduler cat /sys/block/vdb/queue/scheduler [mq-deadline] kyber bfq none
After you resolve the network issue, run the SMC client to retry the operation. For more information, see Run the SMC client.