本文介绍Windows实例更新或安装角色时出现“0x80073712(组件存储已损坏)”错误的问题原因和解决方案。
问题描述
在Windows Server 2012系统的实例中安装更新的时候,出现“0x80073712”错误。使用服务管理器安装新角色的时候,如下图所示,出现“0x80073712(组件存储已损坏)”错误。
问题原因
该错误一般是由于Windows组件存储不一致问题导致的。
解决方案
可以尝试通过如下方式排查分析。
远程连接Windows实例。
具体操作,请参见通过密码或密钥认证登录Windows实例。
打开CMD命令行窗口。
在CMD命令行中输入以下命令,且在每项命令后按Enter键。
DISM.exe /Online /Cleanup-image /Scanhealth DISM.exe /Online /Cleanup-image /Restorehealth
说明根据系统环境不同,该操作可能会比较耗时(10分钟之内)。
再次运行Windows更新或安装所需的相关角色服务。
如果仍然失败,请参考Windows Update补丁更新失败的处理进行处理。
文档内容是否对您有帮助?