全部产品

ARMS Agent安装成功之后控制台上仍无监控数据

KB: 66214

 · 

更新时间:2021-06-23 14:58

问题描述

ARMS Agent安装成功,控制台上仍无监控数据。

问题原因

出现控制台无监控数据的可能原因:

  • 应用无持续的外部请求访问。
  • 查询时间范围不正确。
  • 命令行设置参数顺序。
  • 应用所属地域和ARMS Agent所属地域不一致。
  • ARMS Agent安装目录权限不正确。
  • 应用软件包问题。
  • JDK版本。

解决方案

  1. 应用无持续的外部请求访问。
    如果Agent日志中出现
    “send agent metrics. no metrics.”请确认您的应用是否有持续的外部请求访问,包括HTTP请求、HSF请求和Dubbo请求,并确认开发框架是否在ArmsAgent的支持范围内。关于ARMS应用监控对第三方组件和框架的支持情况,请参见ARMS应用监控支持的Java组件和框架ARMS应用监控支持的PHP组件和框架
  2. 查询时间范围不正确。
    确认选择的查询时间范围是否正确。请您将查询时间条件设为最近15分钟,然后再次确认是否有监控数据。
  3. 命令行设置参数顺序。
    如果是通过-jar命令行启动的,请检查命令行设置,确保-javaagent参数在-jar之前。
    java -javaagent:/{user.workspace}/ArmsAgent/arms-bootstrap-1.7.0-SNAPSHOT.jar -Darms.licenseKey=xxx -Darms.appName=xxx -jar demoApp.jar
  4. 应用所属地域和ARMS Agent所属地域不一致。
    如果ArmsAgent/log/ 下的日志中出
    现“LicenseKey is invalid.”异常,请您检查应用所属地域与Agent所属地域是否一致。
  5. ARMS Agent安装目录权限不正确。
    如果应用启动之后ArmsAgent目录下无log子目录,是由于arms-bootstrap-1.7.0-SNAPSHOT.jar未被成功加载导致的,请您检查ArmsAgent安装目录的权限是否正确。
  6. 应用软件包问题。
    若应用启动时出现以下报错,请您检查arms-bootstrap-1.7.0-SNAPSHOT.jar软件包及相应权限是否正确。
    Application Start Error
  7. 检查JDK版本:
  8. 如果仍无监控数据,请打包Java探针日志(路径:ArmsAgent/log),并联系钉钉服务账号arms160804解决问题。

适用于

  • 应用实时监控服务ARMS

如果您的问题仍未解决,您可以在阿里云社区免费咨询提交工单联系阿里云技术支持。