EDAS应用无法访问页面及RPC服务无法调用

本文主要介绍企业级分布式应用服务EDAS应用无法访问页面及RPC服务无法调用的处理方案。

问题描述

通过HTTP方式无法访问页面,RPC服务无法调用。

问题原因

  1. 服务消费者与服务提供者之间的网络存在问题、应用配置路径错误、应用本身错误等。

  2. 服务器到注册中心网络不可达、服务权限限制、服务调用超时等。

解决方案

通过HTTP方式无法访问页面

  1. 在本机服务器执行curlping等命令确认网页URL是否正常。如果正常,检查访问机到服务机的网络,将网络问题解决后重试。

  2. 若非网络问题,请检查Tomcat安装目录/logs下的日志文件中是否报错,解决所有日志报错。

  3. 排查HTTP路径,特别是应用设置的Context配置和端口配置,确保访问页面路径中的端口与路径与配置一致。设置Tomcat参数

  4. 执行如下命令,查看Java程序进程ID。

    ps -ef |grep java
  5. 依次执行以下命令,通过JVM工具排查程序运行是否正常。

    sudo jstack -F 进程ID
    sudo jstat -class [vmid] [interval] [count];
    jmap -heap 2083
    • [vmid]:VM的进程号,即当前运行的Java进程号。

    • [interval]:间隔时间,单位为秒或毫秒。

    • [count]:打印次数,如果缺省则打印无数次。

RPC服务无法调用

  1. 检查服务调用应用和发布应用是否是同一个账号,且网络可达。

  2. 检查服务器端口是否被屏蔽导致服务无法访问。

  3. 检查服务Tomcat应用日志错误,解决所有日志错误,直到服务列表能正常查询到服务。

  4. 查看/home/admin/logs/hsf/hsf.log日志,确认具体的错误码。具体错误及解决方案,请参见HSF错误码