CreateEciScalingConfiguration - 创建一个伸缩配置

更新时间:
复制 MD 格式

创建一个ECI类型的伸缩配置。

接口说明

伸缩配置用来指定弹性扩张时使用的 ECI 实例模板。

参数 Cpu 和 Memory 用于指定 CPU 和内存定义实例规格的范围,弹性伸缩会结合 IO 优化、可用区等因素确定可用实例规格集合,并根据价格排序为您创建价格最低的实例。该方式仅适用于伸缩组的扩缩容策略为成本优化策略,且伸缩配置未指定实例规格的场景。

调试

您可以在OpenAPI Explorer中直接运行该接口,免去您计算签名的困扰。运行成功后,OpenAPI Explorer可以自动生成SDK代码示例。

授权信息

下表是API对应的授权信息,可以在RAM权限策略语句的Action元素中使用,用来给RAM用户或RAM角色授予调用此API的权限。具体说明如下:

  • 操作:是指具体的权限点。
  • 访问级别:是指每个操作的访问级别,取值为写入(Write)、读取(Read)或列出(List)。
  • 资源类型:是指操作中支持授权的资源类型。具体说明如下:
    • 对于必选的资源类型,用前面加 * 表示。
    • 对于不支持资源级授权的操作,用全部资源表示。
  • 条件关键字:是指云产品自身定义的条件关键字。
  • 关联操作:是指成功执行操作所需要的其他权限。操作者必须同时具备关联操作的权限,操作才能成功。
操作访问级别资源类型条件关键字关联操作
ess:CreateEciScalingConfigurationcreate
*ScalingGroup
acs:ess:{#regionId}:{#accountId}:scalinggroup/{#ScalingGroupId}
    无
无

请求参数

名称类型必填描述示例值
ScalingGroupIdstring是

伸缩配置所属的伸缩组的 ID。

asg-bp14wlu85wrpchm0****
ScalingConfigurationNamestring是

伸缩配置的名称。长度为 2~64 个英文或中文字符组成,以数字、大小写字母或中文开头,可包含数字、下划线(_)、短划线(-)或半角句号(.)。

在同一地域下同一伸缩组内伸缩配置名称唯一。如果您没有指定该参数,则默认使用伸缩配置的 ID。

scalingconfig****
SecurityGroupIdstring是

ECI 实例所属的安全组 ID。同一个安全组内的 ECI 实例之间可以互相访问。

如果没有指定安全组,系统将自动使用您选择的地域下的默认安全组,您需要确保该安全组的入方向规则中包含容器需要暴露的协议和端口。如果您在该地域下没有默认安全组,系统将自动创建一个默认安全组,并将您声明的容器协议和端口添加到该安全组的入方向规则中。

sg-uf66jeqopgqa9hdn****
ContainerGroupNamestring是

ECI 实例名称,即容器组名称。

如果要设置有序名称,格式为name_prefix(AUTO_INCREMENT)[begin_number,bits]name_suffix。

  • name_prefix:指定主机名称的前缀。

  • (AUTO_INCREMENT):固定值,用来标识此排序方式。

  • begin_number:有序数值的起始值,取值范围:[0,999999]。

  • bits:有序数值所占的位数,取值范围:[1,6],当指定的 begin_number 位数大于 bits 的取值时,bits 默认为 6。

说明 bits 建议最少为 3,否则容易达到有序数值的上限。在达到上限后,若还有扩容需求,伸缩活动会报错,并停止扩容。此时,您需要重新设置生成主机名称的规则。
  • name_suffix(可选):指定主机名称的后缀。
说明 [begin_number,bits]中不能有空格,且系统默认依次递增,但是如果存在扩容的 ECI 实例无法启动,会被伸缩组移除后再扩容一台新的 ECI 实例,所以伸缩组内 ECI 实例的主机名称可能断续递增。

示例: 当设置为nginx-test-(AUTO_INCREMENT)[0,3]时,容器组名称为 nginx-test-000、nginx-test-001、nginx-test-002。

设置 ECI 有序实例名称的规则与设置 ECS 伸缩组有序实例规格相同,具体规则介绍,请参见设置有序且唯一的实例名称或主机名称规则。

nginx-test[0,3]
RestartPolicystring否

ECI 实例重启策略。取值范围:

  • Always:总是重启。
  • Never:从不重启。
  • OnFailure:失败时重启。

默认值:Always。

Always
Cpufloat否

实例级别 vCPU 大小。单位:核。

1.0
Memoryfloat否

实例级别内存大小。单位:GiB。

2.0
ResourceGroupIdstring否

资源组 ID。

rg-uf66jeqopgqa9hdn****
DnsPolicystring否

DNS 策略。取值范围:

  • None:使用 DnsConfig 字段设置的 DNS。
  • Default:继承运行环境的 DNS 设置。
Default
ImageSnapshotIdstring否

镜像缓存 ID。

imc-2zebxkiifuyzzlhl****
RamRoleNamestring否

实例 RAM 角色名称。其中,ECI 与 ECS 共用实例 RAM 角色,更多信息,请参见实例 RAM 角色。

RamTestRole
TerminationGracePeriodSecondslong否

程序的缓冲时间,用于处理关闭之前的操作。单位为秒。

60
AutoMatchImageCacheboolean否

是否自动匹配镜像缓存。取值范围:

  • true:是。
  • false:否。

默认值:false。

false
Ipv6AddressCountinteger否

IPv6 地址数。

1
ActiveDeadlineSecondslong否

有效期限。单位为秒。

1000
SpotStrategystring否

实例的抢占策略。取值范围:

  • NoSpot:正常按量付费实例。
  • SpotWithPriceLimit:设置上限价格的抢占式实例。
  • SpotAsPriceGo:系统自动出价,跟随当前市场实际价格的抢占式实例。

默认值:NoSpot。

SpotWithPriceLimit
SpotPriceLimitfloat否

设置抢占式实例的每小时最高价格,最多精确到小数点后 3 位。

当SpotStrategy取值为SpotWithPriceLimit时,必须设置SpotPriceLimit。

0.025
AutoCreateEipboolean否

是否自动创建弹性公网 IP,并绑定 ECI 实例。

true
EipBandwidthinteger否

弹性公网 IP 的带宽。默认为 5 M。

5
HostNamestring否

主机名称,即容器组名称。

test
IngressBandwidthlong否

入方向带宽限制。单位:Byte。

1024000
EgressBandwidthlong否

出方向带宽限制。单位:Byte。

1024000
CpuOptionsCoreinteger否

CPU 物理核心数。仅部分规格支持自定义设置。更多信息,请参见自定义 CPU 选项。

2
CpuOptionsThreadsPerCoreinteger否

每核线程数。仅部分规格支持自定义设置。配置为 1 时表示关闭超线程。更多信息,请参见自定义 CPU 选项。

2
EphemeralStorageinteger否

临时存储空间大小,默认使用 ESSD PL1 类型的云盘。单位:GiB。

20
LoadBalancerWeightinteger否

ECI 实例作为负载均衡后端服务器时的权重,取值范围:1~100。

默认值:50。

50
Tagarray<object>否

实例的标签键值对。

object否

实例的标签键值对。

Keystring否

实例的标签键。N 的取值范围:1~20。

如果传入该值,则不允许为空字符串。最多支持 128 个字符,不能以aliyun和acs:开头,不能包含http://或者https://。

version
Valuestring否

实例的标签值。N 的取值范围:1~20。

如果传入该值,则允许为空字符串。最多支持 128 个字符,不能以acs:开头,不能包含http://或者https://。

3
ImageRegistryCredentialarray<object>否

镜像仓库信息。

object否

镜像仓库信息。

Passwordstring否

镜像仓库密码。

yourpassword
Serverstring否

镜像仓库注册地址。

registry-vpc.cn-shanghai.aliyuncs.com
UserNamestring否

镜像仓库用户名。

yourusername
Containerarray<object>否

实例包含的容器信息。

object否

实例包含的容器信息。

ReadinessProbe.TimeoutSecondsinteger否

检查超时的时间,默认值为 1 秒,最小值为 1 秒。

5
ReadinessProbe.SuccessThresholdinteger否

从上次检查失败后重新认定检查成功的检查次数阈值(必须是连续成功),默认值为 1。当前值必须为 1。

1
SecurityContext.Capability.Addarray否

为容器内的进程授予某些特定的权限。目前仅支持配置为 NET_ADMIN 和 NET_RAW。

说明 NET_RAW 默认不支持,需提交工单申请。
string否

为容器内的进程授予某些特定的权限。目前仅支持配置为 NET_ADMIN 和 NET_RAW。

说明 NET_RAW 默认不支持,需提交工单申请。
NET_ADMIN
ReadinessProbe.TcpSocket.Portinteger否

使用 TCP Socket 方式进行健康检查时,TCP Socket 检测的端口。

8000
ReadinessProbe.HttpGet.Schemestring否

使用 HTTP 请求方式进行健康检查时,HTTP Get 请求对应的协议类型,取值范围:

  • HTTP。
  • HTTPS。
HTTP
LivenessProbe.PeriodSecondsinteger否

检查执行的周期,默认值为 10 秒,最小值为 1 秒。

5
Portarray<object>否

暴露的端口和协议。

object否

暴露的端口和协议。

Protocolstring否

协议类型。取值范围:

  • TCP。
  • UDP。
TCP
Portinteger否

端口号。取值范围:1~65535。

80
EnvironmentVararray<object>否

环境变量。

object否

环境变量。

Keystring否

环境变量名。长度为 1~128 个字符。格式要求:[0-9a-zA-Z],以及下划线(_),不能以数字开头。

PATH
Valuestring否

环境变量值。长度为 0~256 位。

/usr/local/bin
LivenessProbe.TcpSocket.Portinteger否

使用 TCP Socket 方式进行健康检查时,TCP Socket 检测的端口。

8000
Ttyboolean否

是否开启交互。取值范围:

  • true:开启。
  • false:未开启。

默认值:false。

当 Command 为/bin/bash 命令时,需要设置为 true。

false
WorkingDirstring否

容器工作目录。

/usr/local/
LivenessProbe.HttpGet.Schemestring否

使用 HTTP 请求方式进行健康检查时,HTTP Get 请求对应的协议类型,取值范围:

  • HTTP。
  • HTTPS。
HTTP
ReadinessProbe.HttpGet.Portinteger否

使用 HTTP 请求方式进行健康检查时,HTTP Get 请求检测的端口号。

8080
Argarray否

容器启动命令对应的参数。最多 10 个。

string否

容器启动命令对应的参数。最多 10 个。

100
Gpuinteger否

指定容器使用的 GPU 个数。

1
ReadinessProbe.InitialDelaySecondsinteger否

检查开始执行的时间,以容器启动完成为起点计算。单位为秒。

3
Stdinboolean否

此容器是否应在容器运行时为标准输入分配缓冲区。如果未设置,则容器中标准输入的读取值将导致 EOF。

默认值:false。

false
Memoryfloat否

容器内存大小。单位:GiB。

0.5
Namestring否

容器镜像名称。

nginx
Imagestring否

容器镜像。

registry-vpc.cn-hangzhou.aliyuncs.com/eci_open/nginx:latest
LivenessProbe.InitialDelaySecondsinteger否

检查开始执行的时间,以容器启动完成为起点计算。单位为秒。

5
VolumeMountarray<object>否

数据卷挂载信息。

object否

数据卷挂载信息。

MountPropagationstring否

数据卷的挂载传播设置。挂载传播允许将 Container 挂载的卷共享到同一 Pod 中的其他 Container,甚至可以共享到同一节点上的其他 Pod。取值范围:

  • None:该卷不感知任何后续在此卷或其子目录上执行的挂载操作。
  • HostToCotainer:该卷将会感知到后续在此卷或其子目录上的挂载操作。
  • Bidirectional:和 HostToCotainer 类似,能感知挂载操作。另外,该卷将被传播回主机和使用同一卷的所有 Pod 的所有容器。

默认值:None。

None
MountPathstring否

容器挂载数据卷的目录。

说明 容器挂载目录下的内容会被 Volume 的内容直接覆盖,请谨慎使用。
/pod/data
ReadOnlyboolean否

数据卷是否只读。取值范围:

  • true:是。
  • false:否。

默认值:false。

false
Namestring否

数据卷名称。同 Volume 中的 Name。

default-volume1
SubPathstring否

数据卷子路径。

data2/
LivenessProbe.FailureThresholdinteger否

从上次检查成功后认定检查失败的检查次数阈值(必须是连续失败)。

默认值:3。

3
ReadinessProbe.Exec.Commandarray否

使用命令行方式进行健康检查时,在容器内执行的命令。

string否

使用命令行方式进行健康检查时,在容器内执行的命令。

cat /tmp/healthy
ReadinessProbe.FailureThresholdinteger否

从上次检查成功后认定检查失败的检查次数阈值(必须是连续失败)。默认值:3。

3
ImagePullPolicystring否

容器的镜像拉取策略。取值范围:

  • Always:总是拉取。每次都拉取镜像。
  • IfNotPresent:按需拉取。优先使用本地镜像,本地没有镜像时则拉取镜像。
  • Never:从不拉取。使用本地镜像,不拉取镜像。
Always
StdinOnceboolean否

当标准输入为 true 时,标准输入流将在多个附加会话中是否保持开启状态。

如果 StdinOnce 设为 true,标准输入在容器开启时被打开,在首个客户端附加到标准输入之前都为空,然后会一直保持开启状态,接收数据,直到客户端连接断开,此时标准输入被关闭,在容器重启前一直保持关闭状态。

false
Cpufloat否

容器 CPU 核数。

0.25
LivenessProbe.HttpGet.Portinteger否

使用 HTTP 请求方式进行健康检查时,HTTP Get 请求检测的端口号。

8888
LivenessProbe.HttpGet.Pathstring否

使用 HTTP 请求方式进行健康检查时,HTTP Get 请求检测的路径。

/healthyz
LivenessProbe.SuccessThresholdinteger否

从上次检查失败后重新认定检查成功的检查次数阈值(必须是连续成功),默认值为 1。当前值必须为 1。

1
ReadinessProbe.PeriodSecondsinteger否

检查执行的周期,默认值为 10 秒,最小值为 1 秒。

3
LivenessProbe.TimeoutSecondsinteger否

检查超时的时间,默认值为 1 秒,最小值为 1 秒。

1
Commandarray否

容器启动命令。最多 20 个。每个命令最多包含 256 个字符。

string否

容器启动命令。最多 20 个。每个命令最多包含 256 个字符。

sleep
SecurityContext.RunAsUserlong否

设置运行容器的用户 ID。

1000
ReadinessProbe.HttpGet.Pathstring否

使用 HTTP 请求方式进行健康检查时,HTTP Get 请求检测的路径。

/healthz
LivenessProbe.Exec.Commandarray否

使用命令行方式进行健康检查时,在容器内执行的命令。

string否

使用命令行方式进行健康检查时,在容器内执行的命令。

cat/tmp/healthy
LifecyclePostStartHandlerHttpGetHoststring否

使用 HTTP 请求方式设置 PostStart 回调函数时,接收 HTTP Get 请求的主机地址。

10.0.XX.XX
LifecyclePostStartHandlerHttpGetPortinteger否

使用 HTTP 请求方式设置 PostStart 回调函数时,HTTP Get 请求检查的端口号。

5050
LifecyclePostStartHandlerHttpGetPathstring否

使用 HTTP 请求方式设置 PostStart 回调函数时,HTTP Get 请求检测的路径。

/healthyz
LifecyclePostStartHandlerHttpGetSchemestring否

使用 HTTP 请求方式设置 postStart 回调函数时,HTTP Get 请求对应的协议类型,取值范围:

  • HTTP。
  • HTTPS。
HTTPS
LifecyclePostStartHandlerExecarray否

使用命令行方式设置 PostStart 回调函数时,在容器内执行的命令。

string否

使用命令行方式设置 PostStart 回调函数时,在容器内执行的命令。

[ "/bin/sh", "-c", "echo Hello from the postStart handler /usr/share/message" ]
LifecyclePostStartHandlerTcpSocketHoststring否

使用 TCP Socket 方式设置 PostStart 回调函数时,TCP Socket 检测的主机地址。

10.0.XX.XX
LifecyclePostStartHandlerTcpSocketPortinteger否

使用 TCPSocket 方式设置 PostStart 回调函数时,TCP Socket 检测的端口。

80
LifecyclePreStopHandlerHttpGetHoststring否

使用 HTTP 请求方式设置 PreStop 回调函数时,接收 HTTP Get 请求的主机地址。

10.0.XX.XX
LifecyclePreStopHandlerHttpGetPortinteger否

使用 HTTP 请求方式设置 PreStop 回调函数时,HTTP Get 请求检测的端口号。

88
LifecyclePreStopHandlerHttpGetPathstring否

使用 HTTP 请求方式设置 PreStop 回调函数时,HTTP Get 请求检测的路径。

/healthyz
LifecyclePreStopHandlerHttpGetSchemestring否

使用 HTTP 请求方式设置 PreStop 回调函数时,HTTP Get 请求对应的协议类型,取值范围:

  • HTTP。
  • HTTPS。
HTTP
LifecyclePreStopHandlerExecarray否

使用命令行方式设置 PreStop 回调函数时,在容器内执行的命令。

string否

使用命令行方式设置 PreStop 回调函数时,在容器内执行的命令。

[ "/bin/sh", "-c", "echo Hello from the preStop handler /usr/share/message" ]
LifecyclePreStopHandlerTcpSocketHoststring否

使用 TCP Socket 方式设置 PreStop 回调函数时,TCP Socket 检测的主机地址。

10.0.XX.XX
LifecyclePreStopHandlerTcpSocketPortinteger否

使用 TCPSocket 方式设置 PreStop 回调函数时,TCP Socket 检测的端口。

90
Volumearray<object>否

数据卷信息。

object否

数据卷信息。

Typestring否

数据卷类型。取值范围:

  • EmptyDirVolume:EmptyDir 类型的数据卷,表示空目录。
  • NFSVolume:NFS 类型的数据卷,表示网络文件系统。
  • ConfigFileVolume:ConfigFile 类型的数据卷,表示配置文件。
  • FlexVolume:使用 FlexVolume 插件扩展存储类型,支持挂载云盘。
  • HostPathVolume:HostPath 类型的数据卷,表示主机节点的文件或目录。
  • DiskVolume(不推荐):云盘数据卷。建议使用 FlexVolume 挂载云盘。
ConfigFileVolume
DiskVolume.DiskSizeinteger否

DiskVolume 的大小。单位:GiB。

15
NFSVolume.Pathstring否

NFS 数据卷路径。

/share
FlexVolume.FsTypestring否

挂载的文件系统类型,默认取决于 FlexVolume 的 script。

ext4
DiskVolume.FsTypestring否

该系统类型不推荐使用,建议您使用FlexVolume.FsType参数。

xfs
HostPathVolume.Typestring否

Host 目录的类型。例如:File、Directory、Socket 等。

Directory
NFSVolume.ReadOnlyboolean否

NFS 数据卷是否只读。取值范围:

  • true:是。
  • false:否。

默认值:false。

false
HostPathVolume.Pathstring否

Host 上的绝对路径。

/xx/xx/path
FlexVolume.Optionsstring否

FlexVolume 对象选项列表。为 KV 形式,采用 JSON 传递。

例如:通过 FlexVolume 挂载云盘时,Options 的格式为{"volumeId":"d-2zehdahrwoa7srg****","performanceLevel": "PL2"}。

{"volumeId":"d-2zehdahrwoa7srg****","performanceLevel": "PL2"}
FlexVolume.Driverstring否

用于 FlexVolume 的驱动程序名称。

flexvolume
ConfigFileVolumeDefaultModeinteger否

ConfigFileVolume 默认的权限。

0644
NFSVolume.Serverstring否

NFS 服务器地址。

3f9cd4a596-naw76.cn-shanghai.nas.aliyuncs.com
DiskVolume.DiskIdstring否

DiskVolume 的 ID。

d-xx
Namestring否

数据卷名称。

default-volume1
EmptyDirVolume.Mediumstring否

EmptyDirVolume 的存储媒介,默认为空,使用 node 文件系统;支持 memory,表示使用内存。

memory
ConfigFileVolumeConfigFileToPatharray<object>否

配置文件路径列表。

object否

配置文件路径列表。

Pathstring否

配置文件所在的相对文件路径。

PATH
Modeinteger否

ConfigFileVolume 目录权限。

0644
Contentstring否

配置文件内容(32 KB)。

bGl1bWk=
EmptyDirVolume.SizeLimitstring否

EmptyDir 数据卷的大小。取值时请带上单位,建议使用 Gi 或 Mi。

256 Mi
InitContainerarray<object>否

Init 容器列表。

object否

Init 容器列表。

InitContainerEnvironmentVararray<object>否

环境变量信息。

object否

环境变量信息。

Keystring否

环境变量名。长度为 1~128 个字符。格式要求:[0-9a-zA-Z],以及下划线(_),不能以数字开头。

Path
Valuestring否

环境变量值。长度为 0~256 位。

/usr/bin/
SecurityContext.Capability.Addarray否

为容器内的进程授予某些特定的权限。目前仅支持配置为 NET_ADMIN 和 NET_RAW。

说明 NET_RAW 默认不支持,需提交工单申请。
string否

为容器内的进程授予某些特定的权限。目前仅支持配置为 NET_ADMIN 和 NET_RAW。

说明 NET_RAW 默认不支持,需提交工单申请。
NET_ADMIN
Imagestring否

容器使用的镜像。

nginx
InitContainerVolumeMountarray<object>否

数据卷挂载信息。

object否

数据卷挂载信息。

MountPropagationstring否

数据卷的挂载传播设置。挂载传播允许将 Container 挂载的卷共享到同一 Pod 中的其他 Container,甚至可以共享到同一节点上的其他 Pod。可能值:

  • None:该卷不感知任何后续在此卷或其子目录上执行的挂载操作。
  • HostToCotainer:该卷将会感知到后续在此卷或其子目录上的挂载操作。
  • Bidirectional:和 HostToCotainer 类似,能感知挂载操作。另外,该卷将被传播回主机和使用同一卷的所有 Pod 的所有容器。
None
MountPathstring否

挂载目录,容器的挂载目录下的内容被 Volume 的内容直接覆盖。

/usr/share/
ReadOnlyboolean否

挂载路径是否只读。

默认值:false。

false
Namestring否

挂载数据卷的名称。

test-empty
SubPathstring否

数据卷下的子目录,方便 Pod 将同一个 Volume 下不同目录挂载到容器不同目录。

/usr/sub/
ImagePullPolicystring否

镜像拉取策略。

Always
Cpufloat否

容器的 vCPU 大小。单位:核。

0.5
WorkingDirstring否

工作目录。

/usr/local
Commandarray否

容器启动指令。

string否

容器启动指令。

sleep
Argarray否

容器启动参数。

string否

容器启动参数。

10
SecurityContext.RunAsUserlong否

设置运行容器的用户 ID。

587
Gpuinteger否

指定容器使用的 GPU 个数。

1
Memoryfloat否

内存大小。单位:GiB。

1.0
Namestring否

容器名称。

test-init
DnsConfigNameServerarray否

DNS 服务器的 IP 地址列表。

string否

DNS 服务器的 IP 地址列表。

172.10.*.**
DnsConfigSearcharray否

DNS 搜索域列表。

string否

DNS 搜索域列表。

svc.local.kubenetes
DnsConfigOptionarray<object>否

对象选项列表,每个对象由 Name 和 Value(可选)构成。

object否

对象选项列表,每个对象由 Name 和 Value(可选)构成。

Valuestring否

对象变量值。

value
Namestring否

对象变量名。

name
HostAliasearray<object>否

自定义实例内一个容器的 Hostname 映射。

object否

自定义实例内一个容器的 Hostname 映射。

Ipstring否

添加 IP。

1.1.1.1
Hostnamearray否

添加主机名。

string否

添加主机名。

hehe.com
SecurityContextSysctlarray<object>否

系统信息。

object否

系统信息。

Valuestring否

实例运行的安全上下文的变量值。

65536
Namestring否

实例运行的安全上下文系统名称。

kernel.msgmax
NtpServerarray否

NTP 服务器。

string否

NTP 服务器。

ntp.cloud.aliyuncs.com
AcrRegistryInfoarray<object>否

ACR 企业版实例信息。

object否

ACR 企业版实例信息。

Domainarray否

ACR 企业版实例的域名。默认为相应实例的所有域名。支持指定个别域名,多个以半角逗号(,)分隔。

string否

ACR 企业版实例的域名。默认为相应实例的所有域名。支持指定个别域名,多个以半角逗号(,)分隔。

*****-****-registry.cn-beijing.cr.aliyuncs.com
InstanceNamestring否

ACR 企业版实例的名称。

acr-test
InstanceIdstring否

ACR 企业版实例 ID。

cri-nwj395hgf6f3****
RegionIdstring否

ACR 企业版实例所属地域。

cn-beijing
CostOptimizationboolean否

是否开启成本优化开关。取值范围:

  • true:开启。
  • false:未开启。

默认值:false。

false
InstanceFamilyLevelstring否

实例规格族级别,用于筛选符合要求的实例规格范围,当CostOptimization开启时生效。取值范围:

  • EntryLevel:入门级,即共享型实例规格。成本更低,但是无法保证实例计算性能的稳定。适用于平时 CPU 使用率低的业务场景。更多信息,请参见共享型。
  • EnterpriseLevel:企业级。性能稳定且资源独享,适用于对稳定性要求高的业务场景。更多信息,请参见实例规格族。
  • CreditEntryLevel:积分入门级,即突发性能实例。通过 CPU 积分来保证计算性能,适用于平时 CPU 使用率低、偶有突发 CPU 使用率的业务场景。更多信息,请参见突发性能实例概述。
EnterpriseLevel
InstanceTypearray否

指定的 ECS 实例规格,支持指定多个规格(最多支持 5 个)。

string否

指定的 ECS 实例规格。支持指定多个规格(最多支持 5 个),更多信息,请参见指定 ECS 规格创建实例。

ecs.g6.large
DataCacheBucketstring否

数据缓存 Bucket。

default
DataCachePLstring否

数据缓存使用的云盘的性能等级。建议优先使用 ESSD 云盘,该云盘的性能等级取值范围:

  • PL0:单盘最高随机读写 IOPS 1 万。
  • PL1:单盘最高随机读写 IOPS 5 万。
  • PL2:单盘最高随机读写 IOPS 10 万。
  • PL3:单盘最高随机读写 IOPS 100 万。

默认值:PL1。

说明 关于 ESSD 云盘的更多信息,请参见 ESSD 云盘。
PL1
DataCacheProvisionedIopsinteger否

数据缓存使用 ESSD AutoPL 云盘时,ESSD AutoPL 云盘预配置的读写 IOPS。取值范围:0~min{50000, 1000容量-基准性能},其中,基准性能=min{1800+50容量, 50000}。

说明 关于 ESSD AutoPL 云盘的更多信息,请参见ESSD AutoPL 云盘。
40000
DataCacheBurstingEnabledboolean否

数据缓存使用 ESSD AutoPL 云盘时,是否开启 Burst(性能突发)。取值范围:

  • true:开启。
  • false:未开启。

默认值:false。

说明 关于 ESSD AutoPL 云盘的更多信息,请参见ESSD AutoPL 云盘。
false
GpuDriverVersionstring否

指定 GPU 驱动版本。取值范围:

  • tesla=470.82.01(默认值)
  • tesla=525.85.12
说明 仅部分规格支持切换 GPU 驱动版本。更多信息,请参见指定 GPU 规格创建实例。
tesla=525.85.12

返回参数

名称类型描述示例值
object
ScalingConfigurationIdstring

伸缩配置 ID。

asc-uf6fonnghi50u374****
RequestIdstring

请求 ID,唯一标识。

89945DD3-9072-47D0-A318-353284CF****

示例

正常返回示例

JSON格式

{
  "ScalingConfigurationId": "asc-uf6fonnghi50u374****",
  "RequestId": "89945DD3-9072-47D0-A318-353284CF****"
}

错误码

HTTP status code错误码错误信息
403Forbidden.RiskControlForbidden.RiskControl

访问错误中心查看更多错误码。

变更历史

变更时间变更内容概要操作
2025-02-25OpenAPI 描述信息更新、OpenAPI 错误码发生变更查看变更详情
2024-12-03OpenAPI 错误码发生变更、OpenAPI 入参发生变更查看变更详情
2024-01-23OpenAPI 错误码发生变更查看变更详情
2023-11-14OpenAPI 错误码发生变更、OpenAPI 入参发生变更查看变更详情
2023-10-11OpenAPI 错误码发生变更、OpenAPI 入参发生变更查看变更详情
2023-07-12OpenAPI 错误码发生变更查看变更详情
HttpCode错误码错误信息描述
400InstanceType.MismatchThe specified scaling configuration and existing active scaling configuration have different instance type.指定的伸缩配置的实例规格与当前的伸缩配置的实例规格不匹配。
404InvalidDataDiskSnapshotId.NotFoundSnapshot "XXX" does not exist.不存在指定的快照。
400InvalidDataDiskSnapshotId.SizeNotSupportedThe capacity of snapshot "XXX" exceeds the size limit of the specified disk category.指定快照的大小超过了磁盘大小的限制。
403InvalidDevice.InUseDevice "XXX" has been occupied.数据盘挂载点重复。
400InvalidImageId.InstanceTypeMismatchThe specified image does not support the specified instance type.不允许在指定的实例规格下使用该镜像。
404InvalidImageId.NotFoundThe specified image does not exist.该账号下不存在指定的镜像。
400InvalidKeyPairName.NotFoundThe specified KeyPairName does not exist in our records.指定的 KeyPairName 不存在。
400InvalidNetworkType.ForRAMRoleRAMRole can't be used For classic instance.经典网络实例不支持 RamRoleName 参数。
400InvalidParameterThe specified value of parameter KeyPairName is not valid.Windows 操作系统不支持 KeyPairName 参数。
400InvalidParameter.ConflictThe value of parameter SystemDisk.Category and parameter DataDisk.N.Category are conflict.指定的系统盘类型和数据盘类型冲突。
400InvalidRamRole.NotFoundThe specified RamRoleName does not exist.不存在指定的 RamRoleName。
400InvalidScalingConfigurationName.DuplicateThe specified value of parameter ScalingConfigurationName is duplicated.已存在相同的伸缩配置名。
404InvalidScalingGroupId.NotFoundThe specified scaling group does not exist.该账号下不存在指定的伸缩组。
400InvalidSecurityGroupId.IncorrectNetworkTypeThe network type of specified security Group does not support this action.指定的安全组与伸缩组指定网络类型不一致。
404InvalidSecurityGroupId.NotFoundThe specified security group does not exist.该账号下不存在指定的安全组。
400InvalidSecurityGroupId.VPCMismatchThe specified security group and the specified virtual switch are not in the same VPC.指定的安全组和虚拟交换机不属于同一个虚拟专有网络。
403InvalidSnapshot.TooOldThis operation is denied because the specified snapshot is created before 2013-07-15.该快照创建于 2013 年 7 月 15 日或之前,调用被拒绝。
403InvalidSystemDiskCategory.ValueUnauthorizedThe system disk category is not authorized.没有创建临时磁盘系统盘的权限。
400InvalidUserData.Base64FormatInvalidThe specified parameter UserData must be base64 encoded.UserData 不符合 Base64 编码规范。
400InvalidUserData.SizeExceededThe specified parameter UserData exceeds the size.指定的 UserData 过长。
403QuotaExceeded.EphemeralDiskSizeEphemeral disk size quota exceeded.临时磁盘数据盘总容量超过 2 TiB(2048 GiB)。
400QuotaExceeded.ScalingConfigurationScaling configuration quota exceeded in the specified scaling group.您目前拥有的伸缩配置个数已经达到上限。
400QuotaExceeded.SecurityGroupInstanceInstance quota exceeded in the specified security group.指定的安全组中添加的 ECI 实例个数已经达到上限。