通过数据管理DMS登录云虚拟主机的MySQL数据库后,无法看到数据库信息。本文介绍这种情况的可能原因和解决方案。
问题现象
通过数据管理DMS登录云虚拟主机的MySQL数据库,无法看到数据库的任何信息。
可能原因
在本地主机的数据库客户端误删除云虚拟主机的MySQL数据库。
解决方案
选择恢复云虚拟主机MySQL数据库的方法。
您可以通过以下任一方法恢复数据库:
(推荐)通过数据管理DMS恢复数据库。
登录云虚拟主机数据库。
具体操作,请参见通过DMS Web版本登录数据库。
在顶部菜单栏,单击SQL窗口。
在SQL窗口页面的命令行区域,输入以下命令。
create database 云虚拟主机数据库名;
将命令中的
云虚拟主机数据库名
替换为您的主机数据库名称即可。退出数据管理DMS。
通过Navicat for MySQL恢复数据库。
在本地主机启动Navicat for MySQL。
在菜单栏,选择
。在弹出的MySQL-新建连接对话框,输入云虚拟主机的数据库信息,单击连接。
在左侧导航栏,右键单击您新建的连接名,选择打开数据库。
在左侧导航栏,右键单击主机数据库名,选择新建数据库。
在弹出的新建数据库对话框,配置数据库信息,然后单击确定。
新建的数据库配置参数如下所示:
数据库名:设置为您的云虚拟主机数据库名。
字符集:设置为
utf-8
。
数据库新建成功后,左侧导航栏会出现数据库名称节点。
再次通过数据管理DMS连接数据库,检查数据库是否已恢复。
如果问题仍未解决,请提交工单。
文档内容是否对您有帮助?