Windows KMS服务状态异常如何解决?

本文主要介绍Windows KMS服务状态异常的可能原因及其解决方法。

问题现象

当用户在使用ECS实例时,实例与KMS Server之间的连接出现异常。现象

可能原因

  • 用户自定义DNS配置时,未保留至少一个阿里云内网DNS,导致无法成功接入阿里云内网。

  • KMS Server地址配置错误,导致实例无法与KMS Server服务建立连接。

  • 本地网络异常,无法连接KMS Server服务。

解决方案

重要
  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。

  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。

  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。

方案一:检查自定义DNS配置

  1. 使用Win+R组合键打开运行对话框。

  2. 运行窗口中输入cmd,并单击确认打开命令行窗口。

  3. 在命令行窗口输入ipconfig/all命令,并按Enter键。

  4. 检查自定义DNS配置是否至少保留一个阿里云内网DNS。DNS检查

    说明

    若没有保留至少一个阿里云内网DNS,请重新配置DNS。具体操作,请参见如何在Linux实例中自定义配置DNS。

方案二:重新配置KMS Server地址

  1. 使用Win+R组合键打开运行对话框。

  2. 运行窗口中输入cmd,并单击确认打开命令行窗口。

  3. 在命令行窗口依次输入如下命令,并按Enter键。

    slmgr.vbs /ckms
    slmgr.vbs /skms kms.cloud.aliyuncs.com
    slmgr.vbs /ato

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方案三:检查本地网络连接是否正常

  1. 使用Win+R组合键打开运行对话框。

  2. 运行窗口中输入cmd,并单击确认打开命令行窗口。

  3. 在命令行窗口输入ping 100.10X.X.XX命令,并按Enter键测试网络连接是否正常。PING

    说明
    • 若如上图所示,则网络连接正常。

    • 若丢包率为100%则表示无法连接网络,请检查本地网络配置。