通过Workbench远程连接Windows实例提示连接超时,怎么办?
问题现象
通过Workbench工具远程连接Windows实例时提示“登录主机:i-m5e****73a (47.*.*.157:3389) 失败,原因:链接超时!”错误。
问题原因
导致此问题的常见原因如下:
Windows实例的安全组设置不允许Workbench工具连接目标Windows实例。
远程桌面RDP端口不是默认的3389端口。
Windows实例内的防火墙设置未允许Workbench工具连接目标Windows实例。
第三方安全管理软件限制用户远程登录。
解决方案
请参考以下步骤进行排查:
查看目标Windows实例的RDP端口。具体操作,请参见查看ECS Windows远程桌面端口。
不是3389端口
在Workbench工具中通过修改后的RDP端口重试远程连接。
是3389端口
请继续下一步检查。
查看目标Windows实例的安全组设置,检查SSH服务的端口是否放开。具体操作,请参见查询安全组规则。
说明此处的端口范围以RDP默认的端口3389为例。如果您修改过RDP默认端口,此处应当为您修改后的端口号。
授权对象如果不是0.0.0.0/0,则需要同时对您需要访问的ECS实例的IP地址进行授权,此处47.96.60.0/24和118.31.243.0/24为例。
规则方向
授权策略
优先级
端口范围
授权对象
入方向
允许
1
目的:3389/3389
源:47.96.60.0/24和118.31.243.0/24
源:0.0.0.0/0
未放开
请参见上述表格,添加允许Workbench访问的安全组规则。具体操作,请参见使用Workbench工具以RDP协议登录Windows实例。
已放开
请继续下一步检查。
检查Windows实例中是否开启防火墙,且不允许Workbench工具连接RDP端口。检查步骤如下:
通过阿里云VNC方式登录Windows实例。具体操作,请参见使用VNC登录实例。
检查防火墙状态。具体操作,请参见开启或关闭Windows系统防火墙。
已开启,请关闭防火墙,然后通过Workbench工具重试远程连接。
未开启,请继续下一步检查。
检查Windows实例中是否安装第三方安全管理软件,例如安全狗等,并且通过该软件限制用户远程登录。
第三方安全管理软件限制了远程登录
请暂时关闭第三方安全管理软件对远程登录的限制,然后通过Workbench工具尝试远程连接。
未通过第三方安全管理软件限制远程登录
Windows实例中可能存在其他限制远程登录的系统设置,建议您选择阿里云VNC工具进行远程连接。具体操作请参见使用VNC登录实例。
通过Workbench远程连接Windows实例提示用户名或密码不正确,怎么办?
问题现象
通过Workbench工具远程连接Windows实例时提示“登录实例失败,原因:用户名或密码不正确”错误。
问题原因
导致此问题的常见原因如下:
复制粘贴或手动输入了错误的账号或密码。
远程登录用户不属于Remote Desktop Users组。
Windows实例的本地安全策略中被添加了拒绝用户远程登录的策略。
解决方案
请参考以下步骤进行排查:
检查您输入的用户名是否为Administrator。
非Administrator用户
Windows系统中远程桌面RDP默认的用户名为Administrator,如果您未修改过该用户名,请尝试通过该用户名进行远程登录。
是Administrator用户
请继续下一步检查。
请确认您在Workbench中输入了正确的用户名和密码。
输入错误
手动输入用户名和密码时可能存在输入错误的情况,请检查您输入的用户名和密码,确认拼写正确。
说明用户名Administrator拼写错误属于远程连接失败的常见原因之一。
忘记密码
请重置实例密码,然后使用新密码重新登录Windows实例。具体操作,请参见重置实例登录密码。
用户名和密码正确
请继续下一步检查。
如果您曾经修改过Windows实例中的本地安全策略,请检查本地安全策略中是否添加了拒绝用户远程登录的策略。检查方法,请参见通过远程桌面连接Windows实例提示“远程桌面用户组没有该权限”错误怎么办?中的本地安全策略问题的解决方法章节。
说明请先通过阿里云VNC方式登录Windows实例,然后再进行检查。具体操作,请参见使用VNC登录实例。
存在拒绝用户远程登录的策略
在本地安全策略中移除被拒绝远程桌面登录的用户,然后重试远程连接。
未修改过本地安全策略或者不存在拒绝用户远程登录的策略
请继续下一步检查。
如果您使用非Administrator用户远程连接,请检查该用户是否属于Remote Desktop Users组。检查方法请参见通过远程桌面连接Windows实例提示“远程桌面用户组没有该权限”错误怎么办?中的普通用户未附加远程登录权限的解决方法章节。
不属于Remote Desktop Users组
将远程连接用户添加到Remote Desktop Users组,然后重试远程连接。
属于Remote Desktop Users组
Windows实例中可能存在其他限制远程登录的系统设置,建议您选择阿里云VNC工具远程连接。具体操作,请参见使用VNC登录实例。