文档

安装PHP SDK

更新时间:

通过阅读本文,您可以了解安装IMS PHP SDK的方法。

前提条件

  • 已安装PHP 5.3或以上版本。

  • 已安装Composer 2.0或以上版本。

安装PHP SDK

Composer方式安装

  1. 在终端执行composer require alibabacloud/ice-20201109加载服务端SDK。

    命令执行完后,composer.json中依赖的版本如下所示:

    {
        "require": {
            "alibabacloud/ice-20201109": "^1.0"
        }
    }
    说明

    此处依赖的版本号仅供参考,以实际版本为准。获取最新依赖,请参见服务端SDK

  2. 在代码中引入autoload.php文件。

    require __DIR__ . '/vendor/autoload.php';

通过服务端SDK源码安装

  1. 下载并解压服务端SDK源码。下载地址,请参见服务端SDK概览

  2. 在终端执行composer install安装服务端SDK。

  3. 在代码中引入根目录的autoload.php文件。

    require_once '/path/to/ice-sdk/autoload.php';
  • 本页导读 (1)