文档

微服务治理支持的Java框架

更新时间:

本文介绍微服务治理支持的Java框架,您可以根据需要选择合适的JDK和框架版本。

支持的JDK版本

  • JDK 1.8

    说明

    对于Kubernetes集群应用部署,建议使用JDK 8u212及以上版本。

  • JDK 11

    说明

    MSE微服务治理于2.9.x探针版本后支持,建议使用JDK 11.0.17及以上版本。

  • JDK 17

    说明

    MSE微服务治理于2.9.x探针版本后支持,建议您使用JDK 17.0.9及以上版本。

  • JDK 1.7

    说明

    MSE微服务治理于3.0.x探针版本终止支持Java 7,如果您还在使用Java 7,请尽快升级Java版本。更多信息,请参见MSE微服务治理终止支持Java 7公告

支持的JDK发行版

  • OpenJDK(推荐)

  • Alibaba Dragonwell(推荐)

  • Temurin

  • AdoptOpenJDK

  • Amazon Corretto

  • Azul

  • Java HotSpot VM

说明

Eclipse OpenJ9与MSE微服务治理存在一定的兼容性问题,不建议使用。

支持的框架

流量防护和指标监控

分类

框架名称

框架版本

Web

Spring MVC

对应Spring Cloud关联版本

Spring Boot

2.x.x

Spring Cloud

F、G、H、2020.x、2021.x

Feign

对应Spring Cloud关联版本

Java网关

Spring Cloud Zuul

1.3.x

Spring Cloud Gateway

2.0.2 ~ 3.1.8

RPC

Dubbo

3.0.x,2.7.x

数据库

MyBatis

3.4.6 ~ 3.5.15

全链路灰度

分类

框架名称

框架版本

Spring

Spring Boot

2.x.x

Spring Cloud

F、G、H、2020.x、2021.x

Java网关

Spring Cloud Zuul

1.3.x

Spring Cloud Gateway

2.1.x ~ 3.1.8

负载均衡

Spring Cloud LoadBalancer

对应Spring Cloud关联版本

Ribbon

对应Spring Cloud关联版本

注册中心

Nacos

对应Spring Cloud关联版本

Eureka

ZooKeeper

RPC

Dubbo

2.7.x

Web

Tomcat

7.x ~ 10.x

Undertow

1.4.x ~ 2.2.x

消息

RocketMQ

4.x

RocketMQ ONS

1.x及以上版本

无损上下线

分类

框架名称

框架版本

Spring

Spring Boot

2.x.x

Spring Cloud

F、G、H、2020.x、2021.x

Java 网关

Spring Cloud Zuul

1.3.x

Spring Cloud Gateway

2.0.2 ~ 3.1.8

注册中心

Nacos

对应Spring Cloud关联版本

Eureka

ZooKeeper

RPC

Dubbo

2.7.x

  • 本页导读 (1)