本文主要介绍迁移在SMC迁移时,迁移任务出错提示“Client.Rsync.SyncStuck”的原因及解决方案。
问题描述
在SMC迁移时,迁移任务出错提示“Client.Rsync.SyncStuck”。
问题原因
源系统磁盘分区文件数据同步卡住,导致迁移任务超时。
解决方案
检查源系统到目标实例的
IP:8703
端口网络是否正常稳定,源系统带宽速度是否足够,防止因网络带宽过小导致的传输进度过慢而超时。具体检查方式请参考评估迁移时间与测试传输速度。检查源系统磁盘分区是否存在以下情况并处理:
动态变化的大文件,如数据库数据文件或日志文件。
可以考虑在合适的时间点暂停相关数据业务服务,确保迁移的过程中大文件不再动态变化后再试。
使用过滤配置排除相关目录后再试,具体操作,请参见如何过滤、排除不需要迁移的文件或目录。对于未迁移的文件或目录,后续可考虑用其他方案迁移。
大量小文件,如分布式文件系统海量数据、文件服务器等。
使用过滤配置排除相关目录后再试,具体操作,请参见如何过滤、排除不需要迁移的文件或目录。对于未迁移的文件或目录,后续可考虑用其他方案迁移。
问题排查解决后,您可运行SMC客户端进行验证。
该文章对您有帮助吗?