SMC服务器迁移出错提示Client.Snapshot.AccessFailed

本文主要介绍迁移在SMC迁移时,迁移任务出错提示“Client.Snapshot.AccessFailed”的原因及解决方案。

问题描述

SMC迁移时,迁移任务出错提示“Client.Snapshot.AccessFailed”。

问题原因

块复制迁移过程中,SMC客户端会在源系统内部自动创建磁盘分区快照设备,用于数据同步。源系统SMC客户端访问已创建的快照时出错,可能原因如下:

  • Windows:

    • 磁盘分区空间不足。

    • 系统安装有第三方安全杀毒软件。

    • 磁盘分区卷影副本配置的存储使用限制大小不足。

    • 系统卷影副本快照服务Volume Shadow Copy服务异常。

  • Linux

    • 磁盘分区空间不足。

    • 系统可用内存不足300 MB。

    • 磁盘分区快照设备异常。

解决方案

不同操作系统对应的解决方案如下:

  • Windows

    打开事件查看器检查是否有vss、volsnap、disk相关来源异常,并根据报错进行处理。

    • 如果报错提示磁盘空间不足,或VSS卷影副本快照无法增长。

      • 检查磁盘分区剩余空间是否不足,建议预留10% ~ 15%空间。

      • 磁盘卷影副本配置的存储使用限制大小是否不足,建议适当调大使用限制或选择没有限制后再试。

        image

    • 如果报错拒绝访问,错误码0x80070005,需检查系统内是否安装有第三方安全杀毒软件,建议放开磁盘备份权限或者禁用该类软件后再试。

    • 检查系统卷影副本快照服务Volume Shadow Copy服务是否正常。

  • Linux

    检查/dev/smcss9设备是否存在,执行dmesg | grep smcss检查是否有报错。

    1. 检查系统剩余内存是否满足300 MB。

    2. 检查磁盘分区剩余空间是否不足,建议预留10%~15%空间。

    3. SMC客户端安装目录下执行./Check/client_check --ssclear smcss,清理残留快照设备后再试。查找SMC客户端安装目录的具体操作,请参见查看SMC客户端

问题排查解决后,运行SMC客户端再试。具体操作,请参见运行SMC客户端

若仍无法解决,请收集/smc/go2aliyun_client*/Logs日志后联系我们