Windows系统的ECS实例ping外网地址提示“一般故障”错误怎么办?

本文介绍Windows系统的ECS实例ping外网地址提示“一般故障”的错误原因和解决方案。

问题现象

Windows系统的ECS实例ping外网地址时提示“一般故障”错误。

问题原因

出现该问题可能有以下原因:

可能原因

排查方案

ECS实例中安装了第三方杀毒或安全防护软件

检查第三方杀毒软件或安全防火软件

ECS实例内操作系统TCP/IP协议栈损坏,例如注册表损坏。

检查网卡配置信息

ECS实例内组策略中设置了错误的IP安全策略。

检查IP安全策略

解决方案

检查第三方杀毒软件或安全防火软件

如果安装了第三方杀毒或安全防护软件,请尝试卸载第三方软件。然后重新ping外网地址,不再出现“一般故障”错误时,表示该问题已解决。

检查网卡配置信息

执行ipconfig /allroute print命令检查IP配置,查看路由配置是否存在问题。

检查IP安全策略

  1. 远程连接ECS实例。

    具体操作,请参见连接方式概述

  2. 选择开始>运行,输入secpol.msc,单击确定,打开本地安全设置

  3. 单击IP 安全策略,在本地计算机,右键单击已存在的策略,如safe,再单击属性。在safe 属性界面查看安全策略。

    如下图所示,可以看到IP安全策略为指派状态,并且策略为先pass(放行),然后deny(拒绝)。

  4. 右键单击safe,然后单击不指派(U)

  5. 选择开始>管理工具>路由和远程访问,单击禁用本地路由和远程访问(S)20150415161454.jpg

  6. 查看Routing and Remote Accesss服务状态。

  7. 选择开始>运行,输入services.msc,单击确定

  8. 在服务列表中找到Routing and Remote Accesss服务,查看该服务状态。

    1. 若该服务处于禁用状态,表示正常。

    2. 若该服务处于启用状态,右键单击该服务,然后单击禁用

  9. 重新ping外网地址,不再出现“一般故障”错误时,表示该问题已解决。