解决高德地图冲突

冲突说明

mPaaS 内置了高德地图 SDK。如果您的应用因为需要在 Google Play 应用市场上线而同时集成高德官方提供的能通过谷歌审核的版本 SDK 的话,将会出现高德地图冲突的情况。

解决办法

移除 mPaaS 内置的高德地图 SDK。

操作步骤

  1. 确认 mPaaS 所使用的高德地图 SDK 版本,以便您选取相同或相近的过审版本。

    'com.alipay.android.phone.mobilecommon:AMap-2DMap:5.2.1_20190114@jar'
  2. 获取 mPaaS 使用的高德地图 SDK 的 group:artifact 信息。

    'om.alipay.android.phone.thirdparty:amap3dmap-build'
  3. 移除 mPaaS 高德地图 SDK。

    • AAR 方式:

      configurations {
      all*.exclude group:'com.alipay.android.phone.thirdparty', module: 'amap3dmap-build'
      }
    • mPaaS Inside & 组件化(Portal & Bundle):

      mpaascomponents {
      excludeDependencies = [
         "com.alipay.android.phone.thirdparty:amap3dmap-build"
      ]
      }
阿里云首页 移动开发平台 mPaaS 相关技术圈