文档

解决支付宝支付 SDK 冲突

更新时间:

冲突说明

如果您在使用 mPaaS 的同时也使用了支付宝支付 SDK,在部分情况下会出现库冲突的情况。

解决办法

如您遇到支付宝支付 SDK 冲突。

  • 如果您的基线版本是 10.2.3.6 及以上,请添加如下配置。

    configurations {
     all*.exclude group:"com.mpaas.android.anotations", module:"anotations-build"
    }
  • 如果是其他基线版本,请使用以下解冲突支付 SDK 版本。

    dependencies {
     ··· 
     implementation 'com.alipay.sdk.android:alipaysdk-mpaas:15.8.03.210526122749'
     ···
    }