文档

mPaaS 10.2.3 适配 Android 14

更新时间:

谷歌已于 2023 年 10 月 4 日发布 Android 14 正式版。mPaaS 作为基础库,已在 10.2.3 基线上进行了相关适配。在 mPaaS 适配之前,在 Android 14 设备上使用 mPaaS SDK 时 H5 容器和小程序将无法启用 UC 内核,小程序地图 API 在部分机型上可能出现显示异常。

升级 SDK

升级 SDK 前请先确认 assets/custom_config.json 中是否有如下配置:

{
 "value":"{\"h5_enableExternalWebView\":\"YES\",\"h5_externalWebViewSdkVersion\":{\"min\":11,\"max\":34}}",
 "key":"h5_webViewConfig"
}

如果有该配置,需要确认下其中 max 的值是否为 34;如果没有该配置,则不需要处理。

使用 接入/升级基线 来升级 mPaaS SDK 。

  • 如当前基线为 10.2.3,只需升级至 10.2.3.33 或以上版本。参看 10.2.3 发布说明

  • 如当前基线为 10.1.68 或以下版本,请升级至 10.2.3,并更新至 10.2.3.33 或以上版本。参看 mPaaS 10.2.3 升级指南

启用 UC 内核

升级基线到 10.2.3.33 或以上版本后默认启用,无需额外配置。

回归测试

升级 UC 内核可能会伴随部分浏览器特性而发生改动,请对 H5 容器、小程序等使用 UC 浏览器的相关业务进行回归测试。

定制库处理

如果您的依赖中包含定制库,则需要按以下情况处理:

  • 如果您是从低版本 SDK(例如 10.1.68)升级至 10.2.3 版本,您的定制库可能需要基于新版本进行重新定制,请搜索群号 41708565 加入钉钉群咨询 mPaaS 支持人员。

  • 如果您已使用 10.2.3 版本,则只需更新部分组件。参见下文的 适配 Android 14 更新的库清单,检查您的定制库是否包含在其中。

    • 如果不包含,您可继续使用该定制库。

    • 如果包含,您的定制库可能需要重新定制,请搜索群号 41708565 加入钉钉群咨询 mPaaS 支持人员。

适配 Android 14 更新的库清单

  • nebulaucsdk

  • nebulaappproxy

  • 本页导读 (0)