When you bind a domain name in the Web Hosting console, its resolution status may be incorrect or indicate a failure. This topic describes the causes and solutions for this issue.
Symptoms
On the page of the Web Hosting console, the Resolution Status for a domain may be Resolution failed or incorrect. How to resolve. After you bind the domain, the Domain Binding dialog box shows it as bound, but its Resolution Status is Resolution failed or incorrect and its Filing Status is Not filed. You must then configure domain name resolution and complete the ICP filing.
Causes
Possible causes include:
-
The domain name is not resolved.
You should set an A record for the domain name.
-
The domain name is resolved to an incorrect IP address.
The domain name resolves to a different IP address than that of your Web Hosting instance. Modify the DNS record to point to the correct IP address shown in the Expected Resolution Target column. For more information, see Modify a DNS record.
-
The domain name is resolved correctly, but the DNS record has not taken effect.
DNS records take time to propagate. Inquire about the DNS propagation time from your DNS provider.
-
The domain name is resolved and has taken effect. You can use the domain name to access your website from your computer. However, the Web Hosting console shows that the domain name resolution failed or is incorrect.
This may occur because the domain name resolves to multiple IP addresses and the DNS records take effect at random. In this case, the correct DNS record takes effect on your computer, but the DNS server used by the console queries an incorrect IP address. You should delete the redundant IP address records and try to access your website again. For more information, see Delete redundant IP address records.
Solutions
Set an A record
If you have just purchased a domain name, you must set an A record on the Domain Management page when you bind the domain name. For more information, see Set an A record for a domain name.
For more information about how to bind a domain name to a Web Hosting instance, see Bind a domain name.
Modify a DNS record
If your domain name resolves to an IP address different from that of your Web Hosting instance, you must modify the DNS record in the Alibaba Cloud DNS console. For more information, see Modify a DNS record.
Check the DNS propagation time
DNS resolution takes time to propagate. For information about the specific propagation time, contact your DNS provider. If you use a HiChina domain name, see the Time-to-live (TTL) FAQ.
Delete redundant IP address records
This section uses Windows 10 as an example to show how to use the nslookup tool to troubleshoot this resolution issue.
nslookup is a command-line network administration tool used to query DNS records and verify whether domain name resolution works as expected. For more information about this tool, see its official documentation.
-
In the lower-left corner of your desktop, click the
icon, and then type cmdin the search box. -
Click Command Prompt.
-
In the Command Prompt window, run the following command and press Enter.
nslookup -q=a <$Domain>NoteIn the preceding command, replace
<$Domain>with the domain name that you want to bind.-
If the command returns a single IP address and it matches the IP address of your Web Hosting instance, the domain name resolution is correct. No further action is required.
-
If the command returns multiple IP addresses, the domain name resolution is incorrect. Proceed to the next step.
-
-
Log on to the Alibaba Cloud DNS console and delete the redundant IP address records on the Domain Resolution page.
-
Access the website again and confirm that the website is accessible.