This topic answers frequently asked questions about MaxCompute billing.
Category | FAQ |
Billing method | |
Storage fees | |
Compute fees | |
Download fees | |
View bills | |
Switch billing methods | |
Renewal | I activated MaxCompute on a pay-as-you-go basis. How do I disable auto-renewal? |
Resource release | |
Service deactivation |
How is MaxCompute billed?
MaxCompute offers two billing methods:
Pay-as-you-go: Pay for what you use. Resources are shared.
Subscription: Purchase resources before you use them. Resources are dedicated.
MaxCompute billing is project-based. Billable items include data storage, computing, and data downloads. You are charged for storage based on storage size, computing based on the billing method, and public network downloads based on download volume.
For more information about MaxCompute billing methods, see Billable items and billing methods.
If I purchase a monthly subscription for MaxCompute, are there extra fees?
After you purchase a subscription, MaxCompute does not charge additional compute fees during the subscription duration. However, if you download data over the public network or store data while using MaxCompute, you are charged fees based on the data download volume and storage size.
Will I be charged if I perform no operations after purchasing MaxCompute?
After you purchase MaxCompute, you are not charged if you do not download data over the public network, store data, or perform computing operations. If your MaxCompute project contains data, you are charged storage fees even if you do not download data or perform computing operations.
Why am I being billed for MaxCompute when the service is not activated?
Problem description
You receive a bill for MaxCompute, but the console indicates that the service is not activated.
Cause
The root cause is likely that you created and used a MaxCompute project before the product was officially commercialized.
It is important to understand the difference between these two concepts:
MaxCompute service: This refers to the overall activation status of the MaxCompute product under your Alibaba Cloud account. After the product was commercialized, all users must activate the service in the console to use its features, such as computing. If you have not activated the service, the console shows that the service is not activated.
MaxCompute project: This is the specific resource instance where you store data and run jobs. A project created before commercialization remains as an existing resource entity in your account unless it is manually deleted.
Therefore, if a historical project resource still exists in your account, the data stored within it continues to generate storage fees. These fees are charged for the existing resources, such as the project and its data, regardless of whether you have reactivated the service after commercialization.
Solution
To resolve this issue and stop the billing, you must find and delete the historical project. You need to use DataWorks to re-establish the connection and manage the project because the current MaxCompute console cannot directly display historical projects when the service is not activated.
Step 1: Log on to and activate DataWorks
DataWorks is deeply integrated with MaxCompute. By activating DataWorks, you can re-associate and manage the MaxCompute projects under your account.
Go to the DataWorks console.
If prompted, follow the instructions to activate the service. Select the free Basic Edition. This operation does not incur any fees.
Step 2: Find and confirm the MaxCompute project in DataWorks
After you activate DataWorks, the system automatically identifies the compute engine resources associated with your account.
In the navigation pane on the left of the DataWorks console, click Workspaces.
A workspace with the same name as your historical MaxCompute project appears.
Step 3: Delete the historical MaxCompute project
After you confirm the project name, you can return to the MaxCompute console to delete it.
Return to the MaxCompute console. After the association with DataWorks, you can view and manage your historical project.
Find the historical project that you want to delete and go to the project management page.
Perform the delete operation.
ImportantDeleting a project is irreversible. All data and metadata in the project will be permanently destroyed. Before you delete the project, make sure that the data is no longer needed.
Step 4: Confirm that billing has stopped
After the project is successfully deleted, the related storage fees will stop in the next billing cycle. You can visit the Alibaba Cloud User Center to confirm that storage fees for the MaxCompute project are no longer being charged.
MaxCompute stores three replicas. How are they billed?
You are charged for only one replica.
I deleted my pay-as-you-go MaxCompute project. Why am I still being charged CNY 0.01?
According to the storage billing rules, if the actual data storage of a project is greater than 0 MB and less than or equal to 512 MB, you are charged CNY 0.01/day for the project, and . For example, if you delete project data at 09:00 on the current day, a bill is generated on the next day for data storage from 00:00 to 09:00 on the current day.
Are there fees for resources uploaded to MaxCompute?
Data stored in MaxCompute, such as tables and resources, incurs storage fees. These fees are calculated daily based on the data volume.
For more information about storage pricing, see Storage pricing.
After I delete large tables from my MaxCompute project, the displayed storage size does not change. Will my MaxCompute fees increase?
You can check your bill on the day after you delete the tables to see if the charges are correct. Bills are not synchronized in real time. The changes are typically reflected on the next day.
Why do the fees vary significantly when I run SQL queries on different partitions?
The amount of data varies between partitions, so the fees for SQL queries also vary. You can run the desc <table_name> partition(<pt_spec>); command to view the size of a specific partition. To control the computing costs of SQL jobs, see Control computing costs.
Why do my fees fluctuate significantly after I perform a data backfill task in DataWorks?
DataWorks runs a data backfill operation once for each scheduling cycle within the time range you define. For example, if you backfill data for 30 days with a daily scheduling cycle, the data backfill operation is executed 30 times. This causes a significant fluctuation in fees.
Why did my fees increase after I changed the scheduling cycle of a task from daily to hourly in DataWorks?
When you change the scheduling cycle of a task from daily to hourly, the task runs every hour instead of once a day. The number of runs increases, which increases the amount of data read and therefore the fees.
Why do my fees increase after I run a full table scan?
When you run a full table scan, the data input size is the size of the entire table. If you scan only some partitions, the data input size is only the size of those partitions. The fee for an SQL job is calculated as Data input size × Complexity × Unit price. Therefore, if the complexity and unit price remain unchanged, a larger data input size results in higher fees.
Will I be charged if a MaxCompute job fails?
MaxCompute offers two billing models:
Pay-as-you-go: If a job fails, you are not charged.
Subscription: If a job that uses subscription resources fails, no extra fees are charged.
Am I charged for traffic when I download data from MaxCompute over an internal network using an ECS instance?
No. You are not charged for downloading data from MaxCompute over the internal network or a VPC network. Fees are charged only for downloads over the public network. For more information, see Data Transfer Fees (Public Network Download) and .
What is included in the subscription and pay-as-you-go fees on my MaxCompute bill?
The subscription and pay-as-you-go fees on your MaxCompute bill include the following:
Subscription: This includes compute fees for the subscription billing method.
Pay-as-you-go: This billing method covers compute, storage, and outbound traffic for pay-as-you-go resources, and only storage and outbound traffic for subscription resources.
My jobs have not changed, but my fees have increased unexpectedly. What is the cause?
First, identify the SQL jobs that consume the most resources and their specific runtimes by checking your bill. Then, perform a cost analysis and job optimization. For more information, see View bill details or Analyze the usage details of a MaxCompute bill.
I have not used the pay-as-you-go feature of MaxCompute for a long time. Why am I still being charged daily?
Pay-as-you-go fees for MaxCompute include computing, storage, and public network download fees. If there are no computing jobs or public network downloads, check if there is any residual data in your MaxCompute project. Residual data occupies storage space and incurs storage fees. You can view your storage space usage in Project management.
Does switching from pay-as-you-go to a subscription billing method cause data changes or service restarts?
No, it does not cause data changes or service restarts. MaxCompute supports switching between the pay-as-you-go and subscription billing methods. However, you must activate MaxCompute resources for both methods in advance. For more information, see Switch between billing methods.
Can I switch from a subscription to a pay-as-you-go billing method for my MaxCompute project? If so, how are the fees calculated?
Yes, you can switch from a subscription to a pay-as-you-go billing method. For more information, see Switch between billing methods. For information about pay-as-you-go fees, see Storage fees, Data transfer fees (public network download), and Computing fees (pay-as-you-go).
I activated MaxCompute on a pay-as-you-go basis. How do I disable auto-renewal?
The pay-as-you-go billing method for MaxCompute does not have an auto-renewal feature. If you no longer need to use MaxCompute, you can delete and release the stored data to avoid further charges. For more information about deleting data, see Delete a table or a MaxCompute project.
If my MaxCompute service expires or has an overdue payment, how long is my data stored before it is deleted?
If your MaxCompute service expires or has an overdue payment, the service automatically resumes if you settle the overdue payment within 15 days. If the payment is overdue for more than 15 days, Alibaba Cloud considers that you have voluntarily abandoned all your MaxCompute projects. You will receive a text message or email reminder one day before the projects are released. After release, all data in the projects, such as tables, resources, functions, and instances, is permanently deleted and cannot be recovered.
For more information, see Resource release.
How do I disable or deactivate the MaxCompute service?
Perform the appropriate operations based on your MaxCompute project's billing method to avoid incurring fees:
Pay-as-you-go: If you have not created a project, no fees are generated. If you have created a project, delete it in the MaxCompute console to release the resources. For more information about deleting a project, see Delete a table or a MaxCompute project.
Subscription: After you subscribe, you can request a refund online and cancel the service. For more information, see Refund Rules and Process. If you have created projects, make sure that they are no longer needed before you delete them. Alternatively, you can switch the billing method to pay-as-you-go and then request a refund online. For more information about switching billing methods, see Switching between billing methods.