防勒索服务备份数据时,会启动hbrclient
和ids
进程,读取目标文件,需要消耗服务器的内存,在备份任务执行期间,hbrclient
进程会持续存在,备份任务结束后hbrclient
进程通常会被终止。如果服务器中防勒索备份数据缓存目录下的文件较大,可能会使内存占用过高,导致备份任务失败。本文介绍通过修改配置等方式解决内存占用过高的具体操作,您可以根据具体业务需求选取适合您的方案。
问题现象
备份任务状态为备份失败,且错误提示信息为OOM。
问题原因
在备份文件过多、过大或程序运行异常时,可能会导致备份任务占用服务器的内存资源过高。
解决方案
防勒索功能和云备份产品共用同一客户端,因此对防勒索客户端的配置修改,将同样作用于云备份,请在调整前充分评估对云备份服务的影响。
排除网络挂载路径
请勿直接在防勒索的防护目录中添加网络挂载路径(如挂载到ECS服务器上的OSS、NAS地址),此操作可能因频繁的数据访问而产生预期之外的API调用费用。我们为您提供以下三种处理方案:
使用云备份服务:具体操作,请参见快速入门-OSS备份、快速入门-本地NAS备份。
升级客户端:升级至最新版防勒索客户端,系统将自动把挂载目录纳入排除列表。
拆分防护目录:可以尝试将防护策略中的防护目录地址拆分为多个,在同一个防护策略中,多个防护目录会串行执行备份。由于每个拆分目录的数据量相对于原始目录有所减少,每个备份任务消耗的资源也会减少。
例如,您的防护策略中的防护目录为
/user/bin
。可参照下图所示,您可以根据业务需要对防护目录地址进行拆分,具体操作,请参见修改防护策略。
限制备份网络带宽
您可以根据实际业务需求,适当限制备份的吞吐量,可以降低备份对磁盘、内存和CPU的使用。在编辑防护策略面板,修改备份网络带宽限制。具体操作,请参见修改防护策略。
备份网络带宽限制设置为0时,表示不限制带宽。
升级资源配置
备份数据量较大时,需要使用的内存资源较多。如果服务器的内存较小无法满足备份需求,您需要升级服务器的内存配置。具体资源对照,请参见备份所需要的资源说明。
如果您使用的是云服务器 ECS,升级配置步骤,请参见修改实例规格。
拆分防护目录地址后,云安全中心会按照拆分后的目录执行备份计划,不会影响已备份的数据恢复。
调整CPU占用限制
如果您的资源配置与备份数据量相匹配,则可以尝试调高备份的CPU使用占比。这样可以提供更多的计算机资源给备份任务,提高并发处理能力,同时会缩短获取所需资源所带来的等待时间,避免在备份过程中长时间等待,从而整体提高备份速度。
调整CPU占用限制前,请您务必全面评估系统性能及当前负载状况,确保系统具备承受增加负荷的能力。
防勒索与云备份共用同一客户端,因此对防勒索的配置修改,将同样作用于云备份,请在调整前充分评估对云备份服务的影响。
比如您的设备共有8个核,可将默认占用的1核修改为2核。进入防勒客户端的安装目录(默认为../client
目录)在hbr.config
配置文件中添加配置cpu_max_procs = 2
。
不同版本的防勒索客户端的默认安装目录如下:
客户端版本 | 服务器的操作系统 | 防勒客户端的安装目录 |
1.X.X | Windows | C:\Program Files (x86)\Alibaba\Aegis\hbr\client |
Linux | /usr/local/aegis/hbr/client | |
2.X.X | Windows | C:\Program Files (x86)\Alibaba\Aegis\hbrclient\client |
Linux | /usr/local/aegis/hbrclient/client |