备份占用过多磁盘和内存空间解决方案
为了提高数据备份效率,防勒索服务备份数据时,默认会消耗服务器的内存并占用磁盘空间进行数据缓存备份。如果服务器中防勒索备份数据缓存的目录下的文件占用了较大的磁盘空间,或者服务器出现OOM(Out of Memory)问题,可能会导致备份任务失败。本文介绍备份占用过多磁盘和内存空间的解决方案。
占用过多磁盘空间解决方案
问题现象
防勒索备份任务占用服务器的磁盘空间过大。
问题原因
正常情况下,防勒索备份占用服务器的磁盘空间为临时占用,待备份数据上传到云端后,服务器上的备份数据会自动删除。在备份文件过多、过大或程序运行异常时,会出现备份占用服务器的磁盘空间过大的情况。
解决方案一:清理磁盘空间
您可以参考以下步骤清理防勒索备份占用的磁盘空间。
如果服务器开启了云安全中心客户端自保护功能,您需要关闭服务器的客户端自保护功能。
服务器开启客户端自保护功能后,云安全中心会默认保护Agent目录下的文件。只有为服务器关闭客户端自保护功能后,您才能修改Agent目录下的文件,才可以清理防勒索缓存文件。关于客户端自保护的具体操作,请参见客户端自保护。
使用具有管理员权限的用户登录需要操作的服务器。
清理服务器中防勒索备份缓存目录下的缓存文件。
重要防勒索功能已在云端备份需要防护的文件,删除该缓存文件不会对已备份文件产生任何影响。
不同防勒索客户端版本的默认防勒索备份缓存的目录如下表所示,您可以在云安全中心控制台防勒索页面,查看服务器的防勒索客户端版本。
客户端版本
服务器的操作系统
防勒索备份的缓存目录
1.X.X
Windows
C:\Program Files (x86)\Alibaba\Aegis\hbr\cache
Linux
/usr/local/aegis/hbr/cache
2.X.X
Windows
C:\Program Files (x86)\Alibaba\Aegis\hbrclient\cache
Linux
/usr/local/aegis/hbrclient/cache
解决方案二:修改备份缓存配置
您可以参考以下步骤修改备份缓存的位置、状态及占用系统内存空间的上限。
使用具有管理员权限的用户登录需要操作的服务器。
找到并进入防勒索客户端的安装路径。
不同版本的防勒索客户端的默认安装目录如下:
客户端版本
服务器的操作系统
防勒客户端的安装目录
1.X.X
Windows
C:\Program Files (x86)\Alibaba\Aegis\hbr\client
Linux
/usr/local/aegis/hbr/client
2.X.X
Windows
C:\Program Files (x86)\Alibaba\Aegis\hbrclient\client
Linux
/usr/local/aegis/hbrclient/client
进入防勒客户端的安装目录(默认为
../client
目录),创建hbr.config
文件。在
hbr.config
文件中按照以下参数添加数据ID及元数据缓存信息,并保存该文件。通过配置
hbr.config
文件中的参数,可以设置缓存数据存放的位置、缓存数据占用系统内存空间的上限等缓存配置。hbr.config文件的配置示例如下:
disable_blob_cache = false max_blob_cache_weight = 0.15 cache_prefix = D:\CacheFolder max_retain_count = 16 disable_file_cache = false file_cache_max_size_hint = 2g
参数
说明
disable_blob_cache
是否启用数据ID缓存。启用数据ID缓存可以添加备份源服务器的数据ID及元数据缓存来减少备份过程中的网络请求,从而利用数据缓存加速备份。取值:
true:不启用数据ID缓存。
false:启用数据ID缓存。
max_blob_cache_weight
数据ID缓存最多使用系统内存的百分比。
取值范围:(0,1)。默认值0.15,即最多使用15%的系统总内存。
cache_prefix
存放缓存数据的路径。
必须为绝对路径。
max_retain_count
最多保留的数据ID缓存的个数。
取值需为整型。
disable_file_cache
是否启用元数据缓存。取值:
true:不启用元数据缓存。
false:启用元数据缓存。
file_cache_max_size_hint
元数据缓存文件能够使用的磁盘空间的最大值,实际大小可能超出该项设置。
默认值2 GB。
说明2 GB文件缓存至少能支持备份4 TB的数据。
此参数值不得超过磁盘剩余可用空间大小。
此参数设置过小时,会降低缓存的效果,但不会导致备份失败。
说明备份数据缓存文件位置修改完成后,无需重启防勒索备份客户端,下次备份时修改后的配置会自动生效。
OOM问题
问题现象
在防勒索页面的备份任务列表中,备份任务状态为备份失败,且错误提示信息为OOM。
问题原因
防勒索服务备份数据时,在备份数据量很大以及系统资源不足的备份场景下,备份任务会占用较多的系统资源,备份进程会触发OOM被系统终止而导致备份失败。
解决方法
当遇到OOM问题时, 您可以根据实际情况为目标服务器扩充内存或CPU容量, 也可以下文提供的方案尝试解决。
您可以将防护策略中的防护目录地址拆分为多个。在同一个防护策略中,多个防护目录会串行执行备份。由于每个拆分目录的数据量相对于原始目录有所减少,每个备份任务消耗的资源也会减少。
例如,您防护策略中的防护目录设置如下图所示。

那么您可以修改防护策略,将防护目录地址拆分为3个目录,如下图所示。
拆分防护目录地址后,云安全中心会按照拆分后的目录执行备份计划,不影响已备份数据的恢复。
