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无法连接Windows实例

更新时间:

说明

本文档可能包含第三方产品信息,该信息仅供参考。阿里云对第三方产品的性能、可靠性以及操作可能带来的潜在影响,不做任何暗示或其他形式的承诺。

问题描述

用户无法连接Windows实例。

问题原因

无法连接Windows实例的原因较多,不同的问题原因均可能导致无法连接Windows实例。此处列举较为常见的问题原因,具体原因以现场排查结果为准。

  • 防火墙配置异常。

  • 远程访问端口的配置异常。

  • CPU负载过高。

  • 安全组公网规则错误。

  • 修改管理终端密码后未重启ECS实例。

  • 数据盘挂载失败。

  • 客户端本地网络异常。

  • 运营商网络异常。

  • 网卡配置问题。

解决方案

说明

阿里云提醒您:

  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。

  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。

  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。

无法连接ECS实例的排查思路如下所示。

  1. 使用管理终端登录实例

  2. 检查客户端本地网络是否异常

  3. 检查重置实例密码后是否未重启实例

  4. 检查防火墙配置是否异常

  5. 检查安全组公网规则是否异常

  6. 检查远程访问端口配置是否异常

  7. 检查CPU负载是否过高

  8. 尝试重启实例

步骤一:使用管理终端登录实例

无论何种原因导致无法远程连接实例,请先尝试用阿里云提供的远程连接功能进行连接,确认实例还有响应,没有完全宕机,然后再按原因分类进行故障排查。

  1. 登录云服务器管理控制台,单击左侧导航栏中的实例,在目标实例右侧单击远程连接

  2. 在首次连接或忘记连接密码时,单击修改远程连接密码,修改远程连接的密码。

  3. 然后通过远程连接密码连接实例。

步骤二:检查客户端本地网络是否异常

确认是否存在故障现象,如果存在,则参考本步骤解决问题,如果不存在,则执行下一步步骤。

故障现象

用户本地无法连接外网。

故障原因

可能是网卡驱动未开启或网卡配置有问题。

解决方法

使用管理终端登录实例,检查网卡驱动,如果存在异常,则重新安装。

步骤三:检查重置实例密码后是否未重启实例

确认是否存在故障现象,如果存在,则参考本步骤解决问题,如果不存在,则执行下一步步骤。

故障现象

存在实例密码修改记录,但无重启实例记录。

故障原因

可能是修改了实例密码,但是未重启实例。

解决方法

  1. 登录云服务器管理控制台,单击左侧导航栏中的实例

  2. 在页面顶部的选择对应的地域,在目标实例右侧单击更多>实例状态>重启,再单击确认即可。

步骤四:检查防火墙配置是否异常

说明

提示:本文以Windows 2008和2012系统为例。

确认是否存在故障现象,如果存在,则参考本步骤解决问题,如果不存在,则执行下一步步骤。

前提条件

您只有在已授权可关闭防火墙的情况下,才能进行该项排查。

故障现象

远程无法连接,关闭防火墙后连接恢复。

解决方法

调整防火墙配置策略,具体操作请参见如何配置Windows实例远程连接的防火墙。完成操作后,请再进行远程连接,确认连接成功。

步骤五:检查安全组公网规则是否异常

确认是否存在故障现象,如果存在,则参考本步骤解决问题,如果不存在,则执行下一步步骤。

故障现象

无法ping通ECS实例,在排除Iptables和网卡IP配置问题且回滚系统后,仍然无法ping通。

故障原因

可能是ECS实例安全组默认的公网规则被删除。

解决方法

重新配置ECS实例的安全组公网规则,具体操作请参见ECS实例安全组默认的公网规则被删除导致无法ping通

步骤六:检查远程访问端口配置是否异常

确认是否存在故障现象,如果存在,则参考本步骤解决问题,如果不存在,则执行下一步步骤。

故障现象

远程无法连接,远程访问端口非默认端口。

解决方法

  • Windows远程端口设置超出范围导致,您需将端口重新修改为0到65535之间,且没有被占用的其它端口。

    1. 登录实例,依次选择开始>运行,输入regedit,然后单击确认

    2. 打开注册表编辑器,依次选择HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd\Tds\tcp

    3. 双击PortNumber,单击十进制,将原端口由“113322”修改为0到65535之间且不与当前端口冲突的端口,例如5588等端口。

      说明

      注:“113322”为PortNumber右侧显示的端口号。

    4. 再打开HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Tenninal Server\WinStations\RDP-Tcp

    5. 双击PortNumber,单击十进制,将原端口“113322”修改为与第3步一致的端口号。

    6. 然后重启主机,确认远程连接成功。

  • 远程端口修改导致。修改远程连接默认的3389端口后,需要使用IP加端口的方式进行远程桌面连接,如下图所示。

步骤七:检查CPU负载是否过高

确认是否存在故障现象,如果存在,则参考本步骤解决问题,如果不存在,则执行下一步步骤。

故障现象

CPU负载过高导致系统无法进行远程连接。

解决方法

  • 如果杀毒软件在后台执行,请将杀毒软件升级至最新版本或者直接删除。

  • 请使用商业版杀毒软件,或者使用Microsoft Safety Scanner微软免费安全工具,在安全模式下扫描杀毒,相关信息请访问如下链接。 https://www.microsoft.com/security/scanner/zh-cn/default.aspx

  • 检查CPU负载过高时,后台是否正在执行Windows Update操作。

  • 运行Windows Update来安装最新的微软安全补丁。

  • 若应用程序有大量的磁盘访问、网络访问行为、高计算需求,CPU负载过高是正常结果。您可以尝试升配实例规格来解决资源瓶颈问题。

  • CPU负载过高的解决方法请参见Windows系统ECS实例的CPU使用率较高的解决方法

步骤八:尝试重启实例

若用阿里云提供的远程连接功能仍无法成功连接实例,请尝试重启实例。重启操作会使实例停止工作,从而中断业务,请谨慎执行。

说明

注意:重启实例前,需给实例创建快照,用于数据备份或者制作镜像。创建快照的方法请参见创建快照

  1. 登录云服务器管理控制台,单击左侧导航栏中的实例

  2. 在页面顶部的选择对应的地域,在目标实例右侧单击更多>实例状态>重启,再单击确认即可。

适用于

  • 云服务器ECS

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