OSS备份失败,提示“访问OSS Bucket失败,OSS Bucket的访问策略限制访问”,如何解决?
问题现象
OSS备份失败,提示“访问OSS Bucket失败,OSS Bucket的访问策略限制访问,请检查OSS Bucket访问策略和VPC配置确保云备份拥有访问待备份OSS Bucket的权限”。
问题原因
由于OSS Bucket的访问策略设置了限制,导致云备份服务没有权限访问待备份的OSS Bucket。
解决方法
登录OSS控制台。
找到对应的OSS Bucket,在Bucket 授权策略页签,单击新增授权。
授权用户:根据需要选择所有账号,子账号或其他账号进行授权。更多信息,请参见通过Bucket Policy授权访问OSS。
授权操作:选择高级设置。
效力:选择允许。
操作:为云备份访问OSS Bucket需要获取的权限。您可根据如下列表,对操作选择相同的权限。更多信息,请参见服务关联角色。
[ "oss:ListObjects", "oss:GetBucketAcl", "oss:GetBucketLocation", "oss:GetBucketInfo", "oss:PutObject", "oss:GetObject", "oss:PutObjectACL", "oss:GetObjectACL", "oss:PutObjectTagging", "oss:GetObjectTagging", "oss:AbortMultipartUpload", "oss:ListMultipartUploads", "oss:ListParts" ]
条件:勾选访问方式,选择HTTPS。IP设置为192.168.0.0/16。
单击确定。
OSS备份计划删除后,如何删除对应的备份数据?
删除OSS备份计划不会自动清除对应的备份数据,相关数据仍保留在备份库中。如需删除备份数据,请参考如下操作:
在OSS备份页面,切换至恢复任务页签,然后单击创建恢复任务。
在新建恢复任务面板,完成如下操作。
选择包含目标备份数据的备份库。
选择该备份数据所属的Bucket。
选择需删除的备份数据,在其右侧的操作列中单击删除按钮。完成确认,即可删除。
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