从Amazon RDS for SQL Server全量迁移至阿里云

更新时间:
复制 MD 格式

本文介绍如何使用数据传输服务DTS(Data Transmission Service),将Amazon RDS for SQL Server全量迁移至阿里云RDS SQL Server。

前提条件

  • 为保障DTS能够通过公网连接至Amazon RDS for SQL Server,需要将Amazon RDS for SQL Server的公开可用性设置为是。

  • Amazon RDS for SQL Server的数据库版本为2005、2008、2008 R2、2012、2014或2016版本。

  • 已创建阿里云RDS SQL Server实例,详情请参见创建RDS SQL Server实例。

  • 阿里云RDS SQL Server的存储空间须大于Amazon RDS for SQL Server已使用的存储空间。

  • 建议在执行数据迁移前了解DTS支持的能力、优势、限制条件等,详情请参见SQL Server迁移上云指南。

注意事项

  • DTS在执行全量数据迁移时将占用源库和目标库一定的读写资源,可能会导致数据库的负载上升,在数据库性能较差、规格较低或业务量较大的情况下(例如源库有大量慢SQL、存在无主键表或目标库存在死锁等),可能会加重数据库压力,甚至导致数据库服务不可用。因此您需要在执行数据迁移前评估源库和目标库的性能,同时建议您在业务低峰期执行数据迁移(例如源库和目标库的CPU负载在30%以下)。

  • 由于Amazon RDS for SQL Server未开放增量数据迁移所需的sysadmin角色权限,所以暂不支持增量数据迁移。

  • 如果源库中待迁移的表没有主键或唯一约束,且所有字段没有唯一性,可能会导致目标数据库中出现重复数据。

  • 如果待迁移的数据库名称不符合阿里云RDS的定义规范,您需要在配置迁移任务之前在阿里云RDS SQL Server中创建数据库。

    说明

    关于阿里云RDS的定义规范和创建数据库的操作方法,请参见创建数据库。

  • 如需进行增量迁移,请禁用目标库中已启用的触发器和外键,否则会导致迁移任务失败。

  • 对于迁移失败的任务,DTS会触发自动恢复。在您将业务切换至目标实例前,请务必先结束或释放该任务,避免该任务被自动恢复后,导致源端数据覆盖目标实例的数据。

迁移类型说明

  • 结构迁移

    DTS将迁移对象的结构定义迁移到目标实例,目前DTS支持结构迁移的对象为表、视图、表触发器、同义词、SQL 存储过程、SQL 函数、plan guid、自定义类型、rule、default、sequence。

  • 全量数据迁移

    DTS会将Amazon RDS for SQL Server数据库迁移对象的存量数据,全部迁移到阿里云RDS SQL Server数据库中。

    说明

    不支持迁移数据类型为sql_variant的数据。

费用说明

迁移类型

链路配置费用

公网流量费用

结构迁移和全量数据迁移

不收费

通过公网将数据迁移出阿里云时将收费,详情请参见计费概述。

数据库账号的权限要求

数据库

结构迁移

全量迁移

Amazon RDS for SQL Server

SELECT权限

SELECT权限

阿里云RDS SQL Server

读写权限

读写权限

数据库账号创建及授权方法:

全量数据迁移流程

为解决对象间的依赖,提高迁移成功率,DTS对SQL Server结构和数据的迁移流程如下:

  1. 执行表、视图、同义词、自定义类型、rule、default和plan guid的结构迁移。

  2. 执行全量数据迁移。

  3. 执行SQL存储过程、SQL函数、触发器和外键的结构迁移。

迁移前准备工作

  1. 登录Amazon RDS for SQL Server控制台。

  2. 进入Amazon RDS for SQL Server的基本信息页面。

  3. 在安全组规则区域框,单击入站规则对应的安全组名称。

  4. 在安全组设置页面,将对应区域的DTS服务器地址添加至入站规则中,IP地址段详情请参见添加DTS服务器IP地址白名单。

    单击入站页签,然后单击编辑。在编辑入站规则对话框中,将类型设置为自定义 TCP 规则,端口范围设置为 1433,来源选择自定义并填入对应的 DTS 服务器 IP 地址,然后单击保存。

    说明
    • 您只需添加目标数据库所在区域对应的DTS IP地址段。例如,源数据库地区为新加坡,目标数据库地区为杭州,您只需要添加杭州地区的DTS IP地址段。

    • 在加入IP地址段时,您可以一次性添加所需的IP地址,无需逐条添加入站规则。

操作步骤(新版控制台)

  1. 进入目标地域的迁移任务列表页面(二选一)。

    通过DTS控制台进入

    1. 登录数据传输服务DTS控制台。

    2. 在左侧导航栏,单击数据迁移。

    3. 在页面左上角,选择迁移实例所属地域。

    通过DMS控制台进入

    说明

    实际操作可能会因DMS的模式和布局不同,而有所差异。更多信息。请参见极简模式控制台和自定义DMS界面布局与样式。

    1. 登录DMS数据管理服务。

    2. 在顶部菜单栏中,选择Data + AI > 数据传输(DTS) > 数据迁移。

    3. 在迁移任务右侧,选择迁移实例所属地域。

  2. 单击创建任务,进入任务配置页面。

  3. 配置源库及目标库信息。

    警告

    选择源和目标实例后,建议您仔细阅读页面上方显示的使用限制,否则可能会导致任务失败或数据不一致。

    类别

    配置

    说明

    无

    任务名称

    DTS会自动生成一个任务名称,建议配置具有业务意义的名称(无唯一性要求),便于后续识别。

    源库信息

    选择已有连接信息

    • 若您需要使用已录入系统(新建或保存)的数据库实例,请在下拉列表中选择所需的数据库实例,下方的数据库信息将自动进行配置。

      说明

      DMS控制台的配置项为选择DMS数据库实例。

    • 若您未将数据库实例录入到系统,或无需使用已录入系统的数据库实例,则需要手动配置下方的数据库信息。

    数据库类型

    选择SQLServer。

    接入方式

    选择公网IP。

    实例地区

    选择Amazon RDS for SQL Server数据库所属地域。

    说明

    若选项中没有Amazon RDS for SQL Server数据库所属的地域,您可以选择一个该数据库距离最近的地域。

    域名或IP地址

    填入Amazon RDS for SQL Server的访问地址 。

    说明

    您可以在Amazon RDS for SQL Server的基本信息页面,获取数据库的访问地址。

    端口

    填入Amazon RDS for SQL Server的服务端口,默认为1433。

    数据库账号

    填入Amazon RDS for SQL Server的数据库账号,权限要求请参见数据库账号的权限要求。

    数据库密码

    填入该数据库账号对应的密码。

    目标库信息

    选择已有连接信息

    • 若您需要使用已录入系统(新建或保存)的数据库实例,请在下拉列表中选择所需的数据库实例,下方的数据库信息将自动进行配置。

      说明

      DMS控制台的配置项为选择DMS数据库实例。

    • 若您未将数据库实例录入到系统,或无需使用已录入系统的数据库实例,则需要手动配置下方的数据库信息。

    数据库类型

    选择SQLServer。

    接入方式

    选择云实例。

    实例地区

    选择目标RDS SQL Server实例所属地域。

    实例ID

    选择目标RDS SQL Server实例ID。

    数据库账号

    填入目标RDS SQL Server实例的数据库账号,权限要求请参见数据库账号的权限要求。

    数据库密码

    填入该数据库账号对应的密码。

  4. 配置完成后,在页面下方单击测试连接以进行下一步,并在弹出的DTS服务器访问授权对话框单击测试连接。

    说明

    请确保DTS服务的IP地址段能够被自动或手动添加至源库和目标库的安全设置中,以允许DTS服务器的访问。更多信息,请参见添加DTS服务器IP地址白名单。

  5. 配置任务对象。

    1. 在对象配置页面,配置待迁移的对象。

      配置

      说明

      迁移类型

      请同时选中库表结构迁移和全量迁移。

      说明
      • 由于Amazon RDS for SQL Server未开放增量数据迁移所需的sysadmin角色权限,所以暂不支持增量迁移。

      • 为保障数据一致性,数据迁移期间请勿在Amazon RDS for SQL Server中写入新的数据。

      目标已存在表的处理模式

      • 预检查并报错拦截:检查目标数据库中是否有同名的表。如果目标数据库中没有同名的表,则通过该检查项目;如果目标数据库中有同名的表,则在预检查阶段提示错误,数据迁移任务不会被启动。

        说明

        如果目标库中同名的表不方便删除或重命名,您可以更改该表在目标库中的名称,请参见库表列名映射。

      • 忽略报错并继续执行:跳过目标数据库中是否有同名表的检查项。

        警告

        选择为忽略报错并继续执行,可能导致数据不一致,给业务带来风险,例如:

        • 表结构一致的情况下,在目标库遇到与源库主键的值相同的记录:

          • 全量期间,DTS会保留目标集群中的该条记录,即源库中的该条记录不会迁移至目标数据库中。

          • 增量期间,DTS不会保留目标集群中的该条记录,即源库中的该条记录会覆盖至目标数据库中。

        • 表结构不一致的情况下,可能导致只能迁移部分列的数据或迁移失败,请谨慎操作。

      源库对象

      在源库对象框中选择待迁移对象,然后单击向右小箭头将其移动至已选择对象框。

      说明

      迁移对象选择的粒度为Schema、表、列。若选择的迁移对象为表或列,其他对象(如视图、触发器、存储过程)不会被迁移至目标库。

      已选择对象

      • 如需更改单个迁移对象在目标实例中的名称,请右击已选择对象中的迁移对象,设置方式,请参见库表列名单个映射。

      • 如需批量更改迁移对象在目标实例中的名称,请单击已选择对象方框右上方的批量编辑,设置方式,请参见库表列名批量映射。

      说明

      如果使用了对象名映射功能,可能会导致依赖这个对象的其他对象迁移失败。

    2. 单击下一步高级配置,进行高级参数配置。

      配置

      说明

      选择调度该任务的专属集群

      DTS默认将任务调度到共享集群上,您无需选择。若您希望任务更加稳定,可以购买专属集群来运行DTS迁移任务。

      源库、目标库无法连接后的重试时间

      在迁移任务启动后,若源库或目标库连接失败则DTS会报错,并会立即进行持续的重试连接,默认重试720分钟,您也可以在取值范围(10~1440分钟)内自定义重试时间,建议设置30分钟以上。如果DTS在设置的时间内重新连接上源、目标库,迁移任务将自动恢复。否则,迁移任务将失败。

      说明
      • 针对同源或者同目标的多个DTS实例,网络重试时间以后创建任务的设置为准。

      • 由于连接重试期间,DTS将收取任务运行费用,建议您根据业务需要自定义重试时间,或者在源和目标库实例释放后尽快释放DTS实例。

      源库、目标库出现其他问题后的重试时间

      在迁移任务启动后,若源库或目标库出现非连接性的其他问题(如DDL或DML执行异常),则DTS会报错并会立即进行持续的重试操作,默认持续重试时间为10分钟,您也可以在取值范围(1~1440分钟)内自定义重试时间,建议设置10分钟以上。如果DTS在设置的重试时间内相关操作执行成功,迁移任务将自动恢复。否则,迁移任务将会失败。

      重要

      源库、目标库出现其他问题后的重试时间的值需要小于源库、目标库无法连接后的重试时间的值。

      是否限制全量迁移速率

      在全量迁移阶段,DTS将占用源库和目标库一定的读写资源,可能会导致数据库的负载上升。您可以根据实际情况,选择是否对全量迁移任务进行限速设置(设置每秒查询源库的速率QPS、每秒全量迁移的行数RPS和每秒全量迁移的数据量(MB)BPS),以缓解目标库的压力。

      说明

      环境标签

      您可以根据实际情况,选择用于标识实例的环境标签。本示例无需选择。

      配置 ETL 功能

      选择是否配置ETL功能。关于ETL的更多信息,请参见什么是ETL。

      监控告警

      根据业务需求选择是否设置告警并接收告警通知。

      • 不设置:不设置告警。

      • 设置:设置告警。您还需要设置告警阈值和告警联系人,当迁移失败或延迟超过阈值后,系统将进行告警通知。

    3. 单击下一步数据校验,进行数据校验任务配置。

      若您需要使用数据校验功能,配置方法请参见配置数据校验。

  6. 保存任务并进行预检查。

    • 若您需要查看调用API接口配置该实例时的参数信息,请将鼠标光标移动至下一步保存任务并预检查按钮上,然后单击气泡中的预览OpenAPI参数。

    • 若您无需查看或已完成查看API参数,请单击页面下方的下一步保存任务并预检查。

    说明
    • 在迁移任务正式启动之前,会先进行预检查。只有预检查通过后,才能成功启动迁移任务。

    • 如果预检查失败,请单击失败检查项后的查看详情,并根据提示修复后重新进行预检查。

    • 如果预检查产生警告:

      • 对于不可以忽略的检查项,请单击失败检查项后的查看详情,并根据提示修复后重新进行预检查。

      • 对于可以忽略无需修复的检查项,您可以依次单击点击确认告警详情、确认屏蔽、确定、重新进行预检查,跳过告警检查项重新进行预检查。如果选择屏蔽告警检查项,可能会导致数据不一致等问题,给业务带来风险。

  7. 购买实例。

    1. 预检查通过率显示为100%时,单击下一步购买。

    2. 在购买页面,选择数据迁移实例的链路规格,详细说明请参见下表。

      类别

      参数

      说明

      信息配置

      资源组配置

      选择实例所属的资源组,默认为default resource group。更多信息,请参见什么是资源管理。

      链路规格

      DTS为您提供了不同性能的迁移规格,迁移链路规格的不同会影响迁移速率,您可以根据业务场景进行选择。更多信息,请参见数据迁移链路规格说明。

    3. 配置完成后,阅读并选中《数据传输(按量付费)服务条款》。

    4. 单击购买并启动,并在弹出的确认对话框,单击确定。

      您可以在迁移任务列表页面,查看迁移实例的具体进度。

      说明
      • 若迁移实例不包含增量迁移任务,则迁移实例会自动结束。迁移实例自动结束后,运行状态为已完成。

      • 若迁移实例包含增量迁移任务,则迁移实例不会自动结束,增量迁移任务会持续进行。在增量迁移任务正常运行期间,迁移实例的运行状态为运行中。

操作步骤(旧版控制台)

  1. 登录数据传输控制台。

    说明

    若数据传输控制台自动跳转至数据管理DMS控制台,您可以在右下角的jiqiren中单击返回旧版,返回至旧版数据传输控制台。

  2. 在左侧导航栏,单击数据迁移。

  3. 在迁移任务列表页面顶部,选择迁移的目标集群所属地域。

  4. 单击页面右上角的创建迁移任务。

  5. 配置迁移任务的源库及目标库信息。

    类别

    配置

    说明

    无

    任务名称

    DTS会自动生成一个任务名称,建议配置具有业务意义的名称(无唯一性要求),便于后续识别。

    源库信息

    实例类型

    选择有公网IP的自建数据库。

    实例地区

    当实例类型选择为有公网IP的自建数据库时,实例地区无需设置。

    数据库类型

    选择SQLServer。

    主机名或IP地址

    填入Amazon RDS for SQL Server的访问地址。

    说明

    您可以在Amazon RDS for SQL Server的基本信息页面,获取数据库的连接信息。

    在 Amazon RDS 控制台的连接和安全性区域,找到终端节点字段,即为数据库的访问地址。

    端口

    填入Amazon RDS for SQL Server的服务端口,默认为1433。

    数据库账号

    填入Amazon RDS for SQL Server的数据库账号,权限要求请参见数据库账号的权限要求。

    数据库密码

    填入该数据库账号的密码。

    说明

    源库信息填写完毕后,您可以单击数据库密码后的测试连接来验证填入的源库信息是否正确。源库信息填写正确则提示测试通过;如果提示测试失败,单击测试失败后的诊断,根据提示调整填写的源库信息。

    目标库信息

    实例类型

    选择RDS实例。

    实例地区

    选择阿里云RDS SQL Server实例所属地域。

    RDS实例ID

    选择阿里云RDS SQL Server实例ID。

    数据库账号

    填入阿里云RDS SQL Server的数据库账号,权限要求请参见数据库账号的权限要求。

    数据库密码

    填入该数据库账号的密码。

    说明

    目标库信息填写完毕后,您可以单击数据库密码后的测试连接来验证填入的目标库信息是否正确。目标库信息填写正确则提示测试通过;如果提示测试失败,单击测试失败后的诊断,根据提示调整填写的目标库信息。

  6. 配置完成后,单击页面右下角的授权白名单并进入下一步。

    如果源或目标数据库是阿里云数据库实例(例如RDS MySQL、云数据库MongoDB版等),DTS会自动将对应地区DTS服务的IP地址添加到阿里云数据库实例的白名单;如果源或目标数据库是ECS上的自建数据库,DTS会自动将对应地区DTS服务的IP地址添加到ECS的安全规则中,您还需确保自建数据库没有限制ECS的访问(若数据库是集群部署在多个ECS实例,您需要手动将DTS服务对应地区的IP地址添加到其余每个ECS的安全规则中);如果源或目标数据库是IDC自建数据库或其他云数据库,则需要您手动添加对应地区DTS服务的IP地址,以允许来自DTS服务器的访问。DTS服务的IP地址,请参见DTS服务器的IP地址段。

    警告

    DTS自动添加或您手动添加DTS服务的公网IP地址段可能会存在安全风险,一旦使用本产品代表您已理解和确认其中可能存在的安全风险,并且需要您做好基本的安全防护,包括但不限于加强账号密码强度防范、限制各网段开放的端口号、内部各API使用鉴权方式通信、定期检查并限制不需要的网段,或者使用通过内网(专线/VPN网关/智能网关)的方式接入。

  7. 选择迁移对象及迁移类型。

    配置

    说明

    迁移类型

    同时勾选结构迁移和全量数据迁移。

    说明
    • 由于Amazon RDS for SQL Server未开放增量数据迁移所需的sysadmin角色权限,所以暂不支持增量数据迁移。

    • 为保障数据一致性,数据迁移期间请勿在Amazon RDS for SQL Server中写入新的数据。

    迁移对象

    在迁移对象框中单击待迁移的对象,然后单击向右小箭头将其移动至已选择对象框。

    说明
    • 迁移对象选择的粒度为库、表、列。

    • 默认情况下,迁移对象在目标库中的名称与源库保持一致。如果您需要改变迁移对象在目标库中的名称,需要使用对象名映射功能,详情请参见库表列映射。

    • 如果使用了对象名映射功能,可能会导致依赖这个对象的其他对象迁移失败。

    映射名称更改

    如需更改迁移对象在目标实例中的名称,请使用对象名映射功能,详情请参见库表列映射。

    源、目标库无法连接重试时间

    默认重试12小时,您也可以自定义重试时间。如果DTS在设置的时间内重新连接上源、目标库,迁移任务将自动恢复。否则,迁移任务将失败。

    说明

    由于连接重试期间,DTS将收取任务运行费用,建议您根据业务需要自定义重试时间,或者在源和目标库实例释放后尽快释放DTS实例。

  8. 上述配置完成后,单击页面右下角的预检查并启动。

    说明
    • 在迁移任务正式启动之前,会先进行预检查。只有预检查通过后,才能成功启动迁移任务。

    • 如果预检查失败,单击具体检查项后的提示,查看失败详情。

      • 您可以根据提示修复后重新进行预检查。

      • 如无需修复告警检测项,您也可以选择确认屏蔽、忽略告警项并重新进行预检查,跳过告警检测项重新进行预检查。

  9. 预检查通过后,单击下一步。

  10. 在弹出的购买配置确认对话框,选择链路规格并选中数据传输(按量付费)服务条款。

  11. 单击购买并启动,迁移任务正式开始。
    说明 请勿手动结束迁移任务,否则可能会导致数据不完整。您只需等待迁移任务完成即可,迁移任务会自动结束。
    全量数据迁移
  12. 将业务切换至阿里云RDS SQL Server。