短信服务新版SDK源码已经托管至开源平台Github及主流依赖仓库,推荐使用各语言主流的依赖管理工具安装,或通过GitHub clone的方式使用SDK。所有SDK均只依赖SDK核心库,您可以直接使用SDK核心库,使用CommonRequest方式进行调用,Demo代码可通过OpenAPI Explorer生成。

目前,短信服务提供以下编程语言的SDK。

说明
SDK 安装说明 DEMO
Java SDK 安装Java SDK Java SDK DEMO
.NET SDK 安装.NET SDK .NET SDK DEMO
PHP SDK 安装PHP SDK PHP SDK DEMO
Python SDK 安装Python SDK Python SDK DEMO
Node.js SDK 安装Node.js SDK Node.js SDK DEMO
Go SDK 安装Go SDK Go SDK DEMO

短信服务SDK升级说明

2019年1月22日,短信服务发布了新版SDK,此日期后接入SDK的用户使用的均为新版SDK;2019年1月22日前接入的SDK的用户使用的是旧版SDK。相较于旧版SDK,新版SDK有以下优势:
  • 融入阿里云OpenAPI技术体系,改善用户体验。通过新版短信服务SDK,用户可以使用阿里云资源如API Explorer、CloudShell等工具体验API。
  • 阿里云统一维护,降低故障风险。新版短信服务SDK由阿里云SDK统一维护,同时支持自动更新及故障预警,包括Github通知和Deprecated提示等。

新版短信服务SDK提供了更稳定、完善的开发环境,建议您尽快升级SDK