如果您的DBS备份计划在使用过程中出现异常,可以通过本文提供的方法进行修复。
问题描述
备份计划列表页显示DBS备份计划状态异常。
问题原因
DBS备份计划状态显示异常,表示该DBS备份计划下至少存在一个异常任务,通常可能是全量备份任务异常或增量备份任务异常,也可能是其他类型任务出现异常。
任务出现异常时,DBS不会直接启动异常任务,以免影响客户业务。
为了确保您的业务正常进行,备份计划出现异常时,建议您及时排查问题原因。如果参考本文提供的解决方案后仍无法解决问题,请到DBS客户咨询群(钉钉群号:35585947)进行咨询。
解决方案
针对异常的备份任务,DBS提供如下几种解决方案供您参考。
场景及解决方案 | 注意事项 |
若您已确定任务异常的原因,并已成功解决了问题,那么您可以选择单击重新启动来进行修复。 例如备份异常是由于源实例停机导致的,您可以在启动源实例后尝试重启异常任务以解决问题。 |
|
若您已确定任务异常的原因,并已成功解决了问题,那么您可以选择单击忽略错误提示。 例如备份异常是由于客户备份实例关机、服务异常等原因导致,但现已恢复正常,您也可以选择忽略错误提示,下次备份窗口将正常进行备份。 | 若问题已成功修复,忽略操作发起后任务状态将转变为完成。此时如果该备份计划下只有这一条异常任务,那么该备份计划状态会恢复为运行中;如果备份计划仍显示异常,请进一步排查是否存在其他异常任务。 |
若您无法确定异常原因或无法自主确认解决方案,您可以将鼠标停留在感叹号图标上,查看异常信息,并在常见报错文档中搜索异常信息,尝试自行修复。 | 若在常见报错一文中未找到您遇到的异常,或按照文中修复建议仍未解决您的问题,请到DBS客户咨询群(钉钉群号:35585947)进行咨询。 |
操作步骤
登录数据管理DMS 5.0。
在顶部菜单栏中,选择
。说明若您使用的是极简模式的控制台,请单击控制台左上角的图标,选择
。单击备份计划状态列下的立即修复,页面将跳转至异常备份任务页面中。
若异常任务来源是全量备份任务,则跳转至全量数据备份页;若异常任务来源是增量备份任务,则跳转至增量数据备份页。
请根据具体的业务异常备份任务,选择适合的解决方案进行修复。
如果您选择重启异常备份任务,请单击重新启动。
说明如果您正在进行全量备份,在重启异常任务前,请注意备份操作对源库的影响,建议您在业务低峰期进行操作。
如果您选择忽略异常报错,请单击忽略错误提示。
如果您选择自行修复异常的备份任务,可以将鼠标停留在感叹号图标上,查看异常信息。同时请单击查看异常修复建议(异常全量备份任务)或查看增量异常修复建议(异常增量备份任务),页面将跳转至常见报错文档。在该文档中搜索异常信息,并尝试自行修复。
说明若您无法定位异常信息,可能是其他类型任务出现异常,请到DBS客户咨询群(钉钉群号:35585947)进行咨询。
相关文档
如需了解备份恢复过程中常见问题的解决方案,请参见常见报错。