当云虚拟主机上的网站剩余文件(夹)数量不足时,可能会导致网站在写入文件时失败,从而影响网站部分功能的正常使用。本文介绍这种情况的可能原因和解决方案。
问题现象
在云虚拟主机上成功搭建网站并运行一段时间后,网站上的部分功能会无法正常使用。例如,重启云虚拟主机时,主机会一直处于重启等待状态,无法正常启动并且日志也会丢失。

可能原因
网站在使用过程中可能会因程序文件数量较多或者临时产生的缓存文件占用过大等情况,使得网站的剩余文件(夹)数量不足(使用占比已满)时,可能会导致网站在写入文件过程中,无法正常写入,从而影响网站的正常运行。
解决方案
您可以通过清理网站过期文件(夹)或设置文件(夹)数量的预警功能(仅针对独享版云虚拟主机)的方式恢复网站的正常使用。本文以Linux操作系统独享虚拟主机基础版为例,其他类型的主机以实际页面显示为准。
说明 清理网站文件(夹)或设置文件(夹)数量的预警功能前,请提前安装FTP客户端。建议您使用FileZilla工具,具体操作,请参见使用FileZilla管理文件。
- 登录云虚拟主机管理页面。
- 找到待操作的云虚拟主机,单击对应操作列的管理。
- 在站点信息页面的网站信息区域,查看文件(夹)数量。网站的剩余文件(夹)数量不足(使用占比已满)如下图所示:
- 在左侧导航栏,选择 。
- 在文件管理器页面,单击站点根目录。
- 查找并删除占用比例较大的过期文件。本步骤以通过FileZilla工具查找站点根目录下的 文件为例。
- 可选:设置文件(夹)数量的预警功能。为了有效预防因云虚拟主机网站信息页面的文件(夹)数量使用占比已满导致网站无法正常运行,建议您在文件(夹)数量使用占比过满前,设置文件(夹)数量的预警功能。当文件(夹)数量超过报警阈值时,您可以在收到监控报警提示时根据本文解决方案进行操作。