阿里云 Chat App 消息服务提供 WhatsApp 通道创建与完整 Onboarding 支持。本文涵盖通道新建、WABA 绑定、模板配置等全流程操作指南,助您高效接入 WhatsApp Business API。
前提条件
1. 阿里云账号准备
在开始创建WhatsApp通道之前,请确保您已完成以下准备工作:
已开通Chat App服务:Chat App 消息服务控制台。
2. Facebook账号准备
账号状态健康:确保您的Facebook账号状态正常。
身份信息一致:Facebook账号信息中的姓名必须与身份证件上的信息完全一致。
无违规记录:注册人之前没有使用Meta产品的违规行为。
邮箱域名要求:如果注册人使用的邮箱对应的域名是公司域名,该域名相关的账户要没有使用Meta产品的违规行为。
Facebook账号注册:如未注册,请访问 Facebook官网进行注册。
动态验证码设置:为避免收不到验证码导致账户无法登录,建议完成Facebook动态验证码设置。
3. 公司主体信息准备
请准备以下完整并符合要求的公司主体信息:
公司名称和地址:必须与营业执照上的信息完全一致。
公司网站:公司名称必须能在网站中可见。
公司电话:用于Business Manager(BM)认证,必须能接收验证码或语音电话。
银行账单或税单:用于BM认证,必须包含公司名称和公司电话。
认证邮箱:用于BM认证的邮箱域名必须与公司网站域名相同。
4. 手机号准备
准备一个用于注册WABA的手机号。
确保此手机号能收到验证码或语音电话。
操作步骤
步骤一:创建WhatsApp类型通道
在通道管理页面,单击新建通道。
在新建通道对话框,通道类型选择WhatsApp、自定义通道名称。
单击确定,WhatsApp类型通道创建完成。
您可以在通道管理页面,单击通道ID,打开通道操作页面。在通道操作页面可以完成WABA注册及管理、创建WhatApp消息模板和发送WhatsApp消息等操作。
步骤二:创建商业管理账号(Business Manager Account)
创建WhatsApp通道后,您需要创建BM账号。您可以选择以下两种方式之一:
方式一:通过阿里云Chat App控制台创建(推荐)
注册及绑定WABA
WhatsApp Business Account(WABA)是指企业发送WhatsApp商业消息前需要注册的WhatsApp官方业务账户,用于发送商业消息。经过WhatsApp企业认证的WABA会获得认证标志,提高客户对企业信息的信任度,增强品牌形象,减少虚假信息的干扰。
发送WhatsApp消息需要先注册WABA,在Chat App 消息服务中,您可以通过Facebook官方嵌入式快速注册WABA。
您申请WABA时填写的公司信息和注册阿里云Chat App 消息服务时使用的信息应保持一致。
您申请WABA时使用的电话号码,必须是没有注册过WhatsApp的号码且可以正常接收验证码。
注册并绑定WABA:
重要每个通道仅支持与一个 WABA 绑定,如需管理多个WABA 请创建多个通道。
未经过Meta企业认证的 WABA 最多注册两个号码,通过企业认证后可认证 20 个号码,超过 20 个时请联系技术支持向 Meta 申请扩容。
在左侧导航栏,单击
打开Facebook嵌入式注册页面。
说明如果您已登录Facebook或登录的Facebook账号是注册WABA所需账号,请单击以XX的身份继续。
如果您未登录或登录的Facebook账号不是注册WABA所需账号,请单击登录另一账户,按需登录账号或创建新的Facebook账号。
单击开始创建。
说明以下注册步骤仅供参考,最新注册步骤以Meta官网为准。
若您是新建Meta业务账户或WhatsApp Business账号,完成嵌入式注册后,需要WhatsApp审核通过后才能使用。WhatsApp审核通过后,您的WABA会与通道进行绑定并且状态显示为APPROVED,此时可前往号码管理添加、同步、设置号码。
按照页面信息提示,填写业务信息,包括公司名称、公司邮箱、公司官网或业务主页、公司所在国家或地区。单击继续。
说明请填写真实完整的业务信息,否则可能会影响企业认证和OBA(WhatsApp官方商业账号)的申请。
创建WABA,按照页面提示设置WhatsApp Business业务账户名称,选择时区。单击继续。
查看Chat App 消息服务请求获得的权限。单击继续。
说明若要允许Alibaba Cloud Singapore管理您的WhatsApp Business账号(WABA),您必须授予WhatsApp Business账号访问权限和账单管理权限。
等待Facebook验证信息后,单击完成。
方式二:通过Facebook官网创建
登录您的Facebook账户。
访问 Meta Business Suite,按提示填写公司名称和公司网站进行提交。

步骤三:创建WABA(WhatsApp Business Account)
1. WABA注册
紧接上一步BM创建,点击next后进入WABA信息填写界面,按提示完成WABA注册。

2. 新增号码
单击左侧导航栏,进入通道配置页面。
点击。
按实际情况填写号码类型、名称、国家/地区、号码信息。
名称需要与品牌名相关,多个号码显示名最好不重复。例如品牌名为”ABC”,显示名可以是”ABC plus”,”ABC support”。


3. 开通服务并完成认证
开通服务,接收验证码,完成手机号认证。

步骤四:创建消息模板
根据Meta规定,商家给客户的第一条消息必须是模板类型,因此您需要创建符合自己业务场景的模板。
创建模板场景较多,具体可以参见:模板设计。
模板创建完成后才能开始发送消息。
如有疑问可以联系客户经理。
步骤五:企业认证(强烈推荐)
尽管是非必需步骤,但是为避免后续出现账户相关问题,请用户务必完成企业认证。
1. Meta企业认证
点击进入Meta企业认证。
点击 settings。

在左侧菜单栏中点击Security Center,在右侧界面中找到WABA绑定的企业主体,点击Start verification开始企业认证。

2. 完善BM信息(BM information)
公司名称:保持与营业执照上的公司名称一致。
公司地址:保持与营业执照上的公司地址一致。
公司电话:必须保持与银行账单或税单上的电话号码一致。
3. 完成提交BM认证
提交营业执照
提交银行账单和税单:必须包含电话号码。
邮箱验证:通过邮箱接收验证码验证域名。
电话验证:通过接收验证码和语音电话验证电话号码和公司的所属关系。
审核时间:
BM认证审核时间一般为48小时。
请注意查收Meta消息。
超过48小时,可以向您的客户经理反馈。
步骤六:OBA申请(可选步骤)
OBA(Official Business Account)申请是可选的,但可以获得更多权限和功能,并提升品牌可信度。
1. OBA申请条件
BM已经成功通过认证。
您的显示名是approved状态。
2. 进行申请
将需求提交给阿里云客户经理。
提交5个以上品牌相关网站(包含推广您品牌名的文章)。
常见问题
WABA账号被封什么原因?如何解决?
可能原因:
如果BM与WABA名字取得太随意,与公司名和品牌名关联不大,后期会导致WABA被封。
未进行BM认证,也可能导致WABA账号被封。
解决方案:
确保BM和WABA名称与公司名称和品牌名称相关。
务必完成BM企业认证。
因不支持游客浏览被判无效网站链接如何解决?
问题描述:网站链接被Meta判定为无效网址。
解决方案:
需要提交request review。

对自身网站内容以及公司业务内容的相关性做详细描述。
如果还是不行,需联系客户经理提交工单给Meta。
如何建立有效的企业与网站的关联?
为避免被判为无效网址,请确保:
网站可访问性:
网站建设完毕,链接不损坏。
可供其他用户访问。
检查网站访问性的调试器,状态码应为200。
调试工具:https://developers.facebook.com/tools/debug/。

网站内容要求:
网站上应展示公司的品牌标志。
清楚展示公司提供的商品和服务。
域名一致性:
网站域名与电子邮箱域名保持一致。
例如:网站 www.alibaba.com 与邮箱 bob@alibaba.com。
无法收到验证码如何解决?
可能原因和解决方案:
Facebook动态验证码设置:
请进行Facebook动态验证码设置,避免无法接收到验证码。
中国内地电话号码:
如果是中国内地电话号码,接收会不太稳定。
建议联系运营商查询是否信息被拦截。
检查是否有开通国际短信。
Meta账号如果没有进行企业认证,可以进行WABA账号的注册吗?
可以,但有以下限制:
只能添加两个手机号。
每个BM在24小时的滚动周期内,最多给250个电话号码发消息, 该限制是BM维度,意味着一个BM下如果有多个号码,这些号码共享该额度限制。
生产环境下发送消息,如果终端客户举报了,可能导致账号被封。
强烈建议完成企业认证,以获得更好的服务体验和更高的发送限额。
批量发送失败的号码是否可以导出?
目前不支持导出失败号码列表。