排查和处理文件备份客户端状态异常
问题现象
在使用ECS文件备份(经典网络)和本地文件备份时,新版文件备份客户端状态异常,例如客户端状态为未知或已停止。
可能原因
- 备份客户端服务hbrclient运行异常。
- 安装备份客户端的服务器网络异常。
- 备份客户端所在服务器由于更换网卡等原因导致备份客户端注册失败。
解决方案
检查备份客户端的服务运行状态、运行日志和网络情况,重新设置并激活备份客户端。
- 检查备份客户端是否在运行。
- Windows系统
方式一:打开任务管理器查看
hbrclient
进程运行状态。方式二:命令行执行
services.msc
命令,查看Alibaba Cloud Hybrid Backup Service服务运行状态。 - Linux系统
执行
ps -ef | grep hbrclient
命令查看hbrclient进程运行状态。如果存在结果,说明已经启动,一切运行正常。
- 若
hbrclient
服务没有运行,则重启HBR服务即可。Linux系统可执行service hbrclient restart
重启HBR服务。 - 若
hbrclient
服务运行正常,执行步骤2。
- Windows系统
- 检查hbrclient.log日志。新版备份客户端默认安装路径参考如下,操作中请以实际安装路径为准。
- Windows版本日志路径:本地磁盘(C)> Program Files > Aliyun Hybrid Backup Service Client > logs
- Linux版本日志路径:/opt/alibabacloud/hbrclient/logs
- 检查服务器网络状态。新版备份客户端默认安装路径参考如下,操作中请以实际安装路径为准。
- Windows版本日志路径:本地磁盘(C)> Program Files > Aliyun Hybrid Backup Service Client > logs
- Linux版本日志路径:/opt/alibabacloud/hbrclient/logs
- 确认服务器是否换过网卡。联系服务器所在网络的IT支撑人员,确认安装过备份客户端的服务器是否更换过网卡。
- 检查服务器是否被克隆过。联系服务器所在网络的IT支撑人员,确认安装过备份客户端的服务器是否被克隆过。
- 重新激活客户端。
- 选择备份数据源。
- ECS文件备份
在左侧导航栏,选择
。 - 本地文件备份
在左侧导航栏,选择
。
- ECS文件备份
- 在顶部菜单栏左上角,选择所在地域。
- 找到目标备份客户端,在其右侧的操作栏选择 。
- 在重新激活客户端面板,拷贝命令。并在服务器上的客户端安装目录下执行该命令,等待激活成功。
激活完成后,客户端状态显示为已激活。 - 如果以上排查仍未解决问题,请提交工单获取支持。