解压缩文件失败

在主机管理控制台进行网站程序压缩文件的解压缩操作时,可能会因为压缩包文件存在损坏、格式错误或者网站空间已满等原因,导致文件解压缩失败。本文为您介绍解压缩失败的可能原因和解决方案。

问题现象

在云虚拟主机管理控制台上执行文件解压缩操作时显示失败提示,具体报错信息如下所示。

提示失败

可能原因

  • 压缩包文件存在损坏、格式错误等其他问题。例如:

    • 压缩包文件损坏。

    • 压缩包文件格式错误。

    • 压缩包文件设置了密码保护。

    • 压缩包文件中存在中文文件名。

  • 如果使用FTP客户端上传文件时,文件传输方式不是二进制形式。

  • 网站空间已满。

解决方案

说明

如果按照本文方案排查后问题仍未解决,请提交工单获取帮助。

检查压缩包文件

检查项

检查方法或依据

解决方案

确认压缩包文件完整无损

使用FTP客户端将压缩包文件下载到本地,自行检查文件的完整性。

如果压缩包文件有损坏,请及时修复后再次执行解压缩操作。

确认压缩包文件格式正确

  • Linux操作系统云虚拟主机仅支持解压缩.zip和.tar格式的压缩文件。

  • Windows操作系统云虚拟主机仅支持解压缩.zip和.rar格式的压缩文件。

如果压缩包文件格式错误,请根据当前主机限制重新压缩本地文件,然后执行解压缩操作。

确认压缩包文件未设置密码保护

自行检查是否设置密码保护功能。

如果压缩包文件设置了密码保护,则不支持解压缩操作。

确认压缩包文件中不包含中文文件名

自行检查文件名称中是否包含中文。

压缩包文件中存在中文文件名,则不支持解压缩操作。

(可选)检查FTP客户端的传输模式

如果您通过FTP客户端方式上传网站文件至云虚拟主机,请确认FTP客户端的传输模式为二进制(B)模式。具体操作如下:

  1. 使用FTP客户端(如FileZilla)连接云虚拟主机。

    具体操作,请参见使用FileZilla管理文件

  2. 在FileZilla工具页面,选择传输(T) > 传输类型(T)

  3. 确认传输模式选择为二进制(B)模式。

    二级制

检查网站可用空间大小

查看网页空间信息,确认网站可用空间必须大于解压缩后的文件大小。具体操作如下:

  1. 登录云虚拟主机管理页面

  2. 找到待操作的目标云虚拟主机,单击对应操作列的管理

  3. 站点信息页面的网站信息区域,查看网页空间

    说明

    如果您使用的是共享云虚拟主机,且查看网页空间已满,您可以额外购买网页空间。具体操作,请参见增加共享云虚拟主机的网页空间

    查看网页剩余空间