全部产品
云市场
云游戏
    我们项目只有arm64-v8a、armeabi。这样会导致我们加载自己的so库出现UnsatisfiedLinkError异常。这个怎么解决?

我们项目只有arm64-v8a、armeabi。这样会导致我们加载自己的so库出现UnsatisfiedLinkError异常。这个怎么解决?

更新时间:2020-08-21 11:21:37

Sophix包括了arm64-v8a、armeabi、armeabi-v7a、x86 、x86_64五种架构。若超出了用户自己定义的jni架构范围,可以在ndk配置中添加abiFilters进行过滤:

  1. defaultConfig {
  2. ndk {
  3. moduleName "my-native-lib"
  4. abiFilters 'armeabi', 'arm64-v8a'
  5. }
  6. }