问题现象

ARMS Agent安装成功,控制台上仍无监控数据。

可能原因

应用无持续的外部请求访问、应用所属地域和ARMS Agent所属地域不一致、或者ARMS Agent安装目录权限不正确等原因都有可能导致控制台无监控数据。

解决方案

  1. 如果 Agent 日志中出现“send agent metrics. no metrics.”,请确认您的应用是否有持续的外部请求访问,包括 HTTP 请求、HSF 请求和 Dubbo 请求,并确认开发框架是否在 ArmsAgent 的支持范围内。关于 ARMS 应用监控对第三方组件和框架的支持情况,请参见ARMS 应用监控支持的 Java 组件和框架ARMS 应用监控支持的 PHP 组件和框架
  2. 确认选择的查询时间范围是否正确。请您将查询时间条件设为最近 15 分钟,然后再次确认是否有监控数据。
  3. 如果是通过 -jar 命令行启动的,请检查命令行设置,确保 -javaagent 参数在 -jar 之前。
    java -javaagent:/{user.workspace}/ArmsAgent/arms-bootstrap-1.7.0-SNAPSHOT.jar -Darms.licenseKey=xxx -Darms.appName=xxx -jar demoApp.jar
  4. 如果 ArmsAgent/log/ 下的日志中出现 LicenseKey is invalid. 异常,请您检查应用所属地域与 Agent 所属地域是否一致。
  5. 如果应用启动之后 ArmsAgent 目录下无 log 子目录,是由于 arms-bootstrap-1.7.0-SNAPSHOT.jar 未被成功加载导致的,请您检查 ArmsAgent 安装目录的权限是否正确。
  6. 若应用启动时出现以下报错,请您检查 arms-bootstrap-1.7.0-SNAPSHOT.jar 软件包及相应权限是否正确。
    Application Start Error
  7. 如果仍无监控数据,请打包 Java 探针日志(路径:ArmsAgent/log),并联系钉钉服务账号 arms160804 解决问题。
  8. 检查 JDK 版本。如果 JDK 版本为 1.8.0_25 或者 1.8.0_31,可能会出现无法安装探针的情况,建议您升级对应的 JDK 版本,或咨询钉钉服务账号 arms160804