通过远程桌面连接Windows实例提示“没有远程桌面授权服务器可以提供许可证”错误怎么办?

本文介绍通过远程桌面连接Windows实例提示“没有远程桌面授权服务器可以提供许可证”错误的解决方案。

问题描述

使用远程桌面连接Windows实例,输入正确的用户名和密码后,无法正常远程连接,并提示如下错误信息。

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原因分析

Windows Server系统默认支持最多同时两个远程桌面连接会话数。如果需要支持大于两个会话数,或者需要对访问设备或用户进行权限控制,则需要安装远程桌面服务并购买配置RDS CAL(远程桌面服务客户端访问许可证)。

安装远程桌面服务后,从第一次连接远程桌面开始,系统会进入120天的许可宽限期。在宽限期内,用户可以正常进行远程桌面连接而无需立即购买RDS CAL,在此期间,默认最多同时支持两个远程桌面连接会话数。当宽限期结束后,必须购买并配置RDS CAL才能继续正常使用远程桌面连接,否则将无法建立连接,会出现该错误提示。

解决方案

方案一:删除远程桌面服务相关的角色

本文以Windows Server 2016操作系统为例,为您介绍如何删除相关服务角色。

  1. 通过VNC连接Windows实例。

    具体操作,请参见使用VNC登录实例

  2. 右键单击开始,然后单击运行,在对话框中输入servermanager,单击确定

  3. 服务器管理器页面,删除远程桌面服务。

    1. 选择管理 > 删除角色和功能删除远程桌面zh.png

    2. 服务器选择页面,保持选择默认Windows实例,单击下一步

    3. 服务器角色页面,取消勾选远程桌面服务。在弹出的对话框中,单击删除功能,然后单击下一步image

    4. 功能页面,取消选中远程服务器管理工具,然后单击下一步

    5. 确认页面,单击删除

    6. 结果页面,查看删除任务进度。

  4. 等待删除任务完成后,重启Windows实例。

    • 方式一:在ECS控制台上重启Windows实例,具体操作,请参见重启实例

    • 方式二:在Windows实例桌面,右键单击开始选择关机或注销 > 重启

  5. 尝试使用RDP连接工具或Workbench进行登录。具体操作,请参见通过密码或密钥认证登录Windows实例

方案二:购买并配置相应的RDS CAL进行授权

购买并配置相应的RDS CAL进行授权。具体操作,请参见微软官方文档